i m running solaris 10 on my pc and i have installed php 5.2.1 from the solaris freeware site

i want to install the ssh2 pecl extension and i tried to do this using the pecl command and it didnt work giving me an error "pecl install ssh2-beta
No releases available for package "pecl.php.net/ssh2"
Cannot initialize 'ssh2-beta', invalid or missing package file
Package "ssh2-beta" is not valid
install failed"


i also tried installing using pear command but it gave me an error saying php does not have zlib support.

if anyone can tell me how I can install php along with zlib I'd be grateful or any other way of installing the ssh2 extension for php.