Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all. I found that MC doesn't come with Yoper by default, so i compiled it by myself. Now i have some problems with it as follows: In konsole it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Israel
    Posts
    22

    Midnight Commander issues


    Hi all.
    I found that MC doesn't come with Yoper by default, so i compiled it by myself. Now i have some problems with it as follows:
    In konsole it appears different. E.g. if i start it with "mc" command, it's interface is built of letters, not lines, mouse doesn't work and function keys too. However if i start it with konsole built-in option for new session everything is fine. Same for root. It make me sick, please help me to fix it.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Have you tried restarting X? I'm not sure that would help, but it can't hurt. Also...does mc work correctly in a regular vt?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Israel
    Posts
    22
    sarumont
    Off course i restarted X, but it didn't help.
    I just switched from Mandrake and there a workaround for MC's look was disabling a framebuffer (i really don't know why, but it worked). So i disabled a framebuffer here in Yoper but nothing happened.
    And yes, MC works ok in regular terminal and more than this, it works ok if i start it with Konsole's "Session > New Midnight Commander" dialog, but not when i start it from within Konsole with "mc" command. I must fix it, i hate things not working as they have to work.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    Better late than never?

    "And yes, MC works ok in regular terminal and more than this, it works ok if i start it with Konsole's "Session > New Midnight Commander" dialog, but not when i start it from within Konsole with "mc" command"
    -------

    I realize I'm running a little behind here... but just in case you're still in need...

    I use mc in ALL my distros, it is the FIRST package I want!

    I've had a similar problem... try this: with mc "up", "Settings, Font, Unicode." And don't forget to save the changes. Next time mc should start up normally. (Like you expect.)

  6. #5
    Just Joined!
    Join Date
    Dec 2004
    Location
    Dallas, Texas
    Posts
    2
    Hi, I had this problem too, and not just with mc, in fact with any ncurses based program that is attempting to draw lines or boxes. The simple fix is to put the following in your .bashrc (or the rc of whatever shell you are using:

    export TERM=xterm

    For some reason, Yoper sets TERM to linux, and I am guessing unicode isn't supported that way.

    After you set TERM=xterm, *all* of your ncurses programs, including mc, will behave as you would expect.

  7. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    Great TIP

    export TERM=xterm

    For some reason, Yoper sets TERM to linux, and I am guessing unicode isn't supported that way.

    After you set TERM=xterm, *all* of your ncurses programs, including mc, will behave as you would expect.
    Thanks Mac, really great tip.

    Post edit: O.K., went to /etc/bashrc which was sym-linked to /etc/profile and down near the bottom of the file changed, 'TERM=linux' to 'TERM=xterm'.

    Thanks again Mac! Cool!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •