Find the answer to your Linux question:
Results 1 to 2 of 2
Dear all, I'm trying to install a program that requires the guile-devel package. I've managed to install it before, however, I'm unable to do so now while I saved and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    2

    Guile-devel headers


    Dear all,

    I'm trying to install a program that requires the guile-devel package. I've managed to install it before, however, I'm unable to do so now while I saved and re-used the syntax I used previously.
    During the configure stage I get these messages:

    checking for guile-config... unknown
    checking for readline in -lreadline... no
    checking for dlopen in -ldl... yes
    checking for scm_lt_dlinit in -lguile-ltdl... no
    checking for dlopen in -lltdl... yes
    checking for gh_eval_str in -lguile... no
    configure: error: linking to guile failed

    From this I thought that I'm either not linking correctly to the guile library or headers. I have however put the guile library directory in the LDFLAGS. Which suggests I'm not linking to the guile-devel headers. I think guile-devel is installed (considering I managed to install the program before) but I'm not sure:

    yum list | grep guile
    guile.x86_64 5:1.6.4-14 installed
    guile.i386 5:1.6.4-14 sl-base
    guile-devel.x86_64 5:1.6.4-14 sl-base

    Naturally I do not have admin rights to perform a yum install or yum update.
    I've tried finding the guile / guile-devel headers but without any succes.

    I've also tried to find any .pc file that is related to guile so that I might be able to fool the configure script into using pkg-config instead of guile-config however I found none.
    Scientific Linux SL release 4.3 (Beryllium)
    Any ideas how I can find the guile / guile-devel headers?

    Thanks,

    Jamie

  2. #2
    Just Joined!
    Join Date
    Feb 2011
    Posts
    2
    I've managed to get it installed. Still don't know what the issue was though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •