Find the answer to your Linux question:
Results 1 to 7 of 7
So I have been searching for a Linux distro that provides both a very good package manager (one that also manages dependencies, because I am very lazy) as well as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    Monitor problems with Yoper...


    So I have been searching for a Linux distro that provides both a very good package manager (one that also manages dependencies, because I am very lazy) as well as an installation process that is as automated as it can be, because whenever I try to do a Slackware (or similar) install I will mess something up. Actually, I tried installing College Linux, Slackware, and Evil Entity- and none of them would even recognize my USB mouse and keyboard, or the PS/2 keyboard that I had plugged in to do the installation. In other words, I wanted something that was very friendly towards "hands-off" users such as myself.

    It's also worth mentioning that I can't do anything that involves FTP, because the college that I go to has the stupidest network in the world. Apparently the ports required for FTP aren't open, or something. This makes Debian (I installed Knoppix for a while) not so good for me, because most of the apt-get stuff you do seems to be FTP, and the apt-get doesn't manage dependencies anyway, unless it does and I just couldn't figure out how to make it.

    Yoper looked like a good distro to choose, and it has the bonus of being really, really fast.

    Everything in the install went well. It's all autodetected and configured, and the slacker in me is most overjoyed. I could even use my USB keyboard to type stuff, and my USB mouse! Awesome. Then I got to the part where SaX runs to configure your video card or something. It starts running, and my monitor flickers off and displays a message that says something like "Sync out of range." This stays this way until I hit "Enter," at which time SaX loops a message that says it will only need to do this once, and if the message displays again to restart.

    I am running an ATI Radeon 9700 Pro or Plus or whatever the addition at the end is. My processor is an Athlon XP 2800+. My monitor is a Samsung Syncmaster 950b.

    I was looking through these forums and saw several other people with my problem, but I was unable to fix the problem using any of the methods suggested. One person suggested switching out monitors or something, but I am just not able to do that.

    Another person suggested running Knoppix and copying my XFree86 config files to my Yoper partition. I tried this, but I was unable to get write access to my Yoper partition, even when I did the whole "chmod" and "chown" thing. Can someone suggest something else to try, or give me some guidance on how to do the Knoppix thing? Like, how do I get write access to the partition? Which files do I need to copy from the Knoppix directory? I saw a file that was called something like "XFree86config. Pre-SaX"- do I need to delete that also to keep SaX from running?

    I appreciate the help. Yoper looks really cool, you know, as soon as I can get it to display on my monitor and stuff.

  2. #2
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    Soooooooooo, Are you running Yoper right now? Are you able to view the desktop? Did you know that Yoper and Knoppix are both Debain based distro?
    Knoppix is a live CD only, you need to install it to use app-get, and then it will not be Knoppix any more, but Debain. Did Knoppix auto-detect your system ok? The only other distro you might want to try is Mepis, it too is a live CD, if it loads and works for your system, then you can install it.

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2
    I am not able to use Yoper at the moment. As I said, the install process grinds to a halt when SaX starts running.

    I installed Knoppix to my hard drive (It thus became Debian apparently), and the apt-get function was really weird for me to use because of the way my college's Internet works. We can't access FTP stuff at all, it just doesn't work. I don't know why, but it doesn't.

    Since a lot of the apt-get stuff relies of apt-get, it didn't really work for me as a package manager. I didn't realize that Yoper relied on a similar system, although it at least manages dependencies (if I am to understand correctly, anyway), which the Debian I installed from the Knoppix disc did not seem to do. Are there alternate sources I could add to my sources.list that are http?

    Knoppix autodetected all of my stuff perfectly; it has been the only distro of any sort I have tried that didn't fail to recognize at least one very important piece of my computer's hardware. This is weird, because Yoper looked like it was autodetecting all my stuff too, until the SaX thing set the sync rate for my monitor wrong or something.

    What distro is Mepis based off of? I had never heard about it before.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    Warsaw, Poland
    Posts
    87
    Please read about the major linux distros on www.distrowatch.com, you can also take a look at my home page www.distrochooser.prv.pl - there is a little comparison between major linux distros there and a little test helping to choose the right distro for you.

    Debian is known to have THE BEST PACKAGE MANAGEMENT TOOL (apt-get) which DOES handle dependencies. Dunno why you thought it didn't. Also, Debian's apt-get doesn't have to use FTP. It can be easily configured to use HTTP instead. The same goes for other debian-based distros like Ubuntu, Mepis, Knoppix, Libranet or Xandros.
    Actually it also is true for Yoper which uses debian's apt-get tool, only with RPM packages (debian uses DEB package format).

    Quote Originally Posted by TheBlessedLunatic
    I am not able to use Yoper at the moment. As I said, the install process grinds to a halt when SaX starts running [...] This is weird, because Yoper looked like it was autodetecting all my stuff too, until the SaX thing set the sync rate for my monitor wrong or something
    Did you check the proper sync rates for your monitor on the official webpage? SaX doesnt always do the best job guessing the right monitor syncs. Also you could try to lower the resolution (say to 1024x768 to start off) and if it works, then try greater ones.
    Hope it helped.

  6. #5
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    Mepis is also a Debian based distro, it is a live CD to try on one's system, if it boots the system up, then on the desktop is an icon to install it. Mepis is the most simplest Linux distro I have ever used and I do recommend Mepis for noobies.

    Now back to Yoper: During the install, if hot plug can not detect your monitor or video card/chip, then the SAX2 configurator will come up. At this point in time, you test and configure the video system to use until you can find and install the right driver. But with SAX2 not working the best thing to do is restart the install and when the configurator comes up, play with that. Or, use Knoppix to copy it's video info over to Yoper.

  7. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4
    I've had similar issues when trying to install on my laptop. Here's what worked for me...

    If you know what your hardware is, instead of accepting the default configuration that Sax2 presents (intial boot after install) click on the "change the configuration" button and go through the entire sequence of choosing your monitor, video card, color and resolution and enabling 3d if your card is such. Click finish and test your configuation. If all is well, you should have a usable configuration ..... save it, finish and continue.

    Funny thing is that even though the intial Sax2 appears to have correct settings, in my case it didn't work until I went through the change and setup sequence. Hope this helps...Yoper is a fast and fun OS

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Location
    Canada
    Posts
    35
    I had the same problem too, and have some suggestions you can look into if the steps vanshark mentioned don't help:


    First, it's a really good idea to have on hand the vsyn and hsyn ranges for your monitor... I think that was where things were screwing up the most.

    If after using SaX it doesn't work, continue installation and then run xf86config (not xf86cfg .. that one did me no good) from the console prompt once Yoper is done installation. I dunno why, but on both the laptops that I installed Yoper on, SaX didn't help, but running through the config process with xf86config got it going perfectly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •