Find the answer to your Linux question:
Results 1 to 2 of 2
I just installed yoper in my hda4 partition which was formatted by yoper as reiserfs (hda1 Windows NTFS, hda2 Windows FAT32, hda3 swap) and during the installation i chose to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96

    Boot Manager Question.


    I just installed yoper in my hda4 partition which was formatted by yoper as reiserfs (hda1 Windows NTFS, hda2 Windows FAT32, hda3 swap) and during the installation i chose to install grub on hda4. I knew that would create a problem of not being able to boot into linux since there is no option for bootdisk in the installation. I want to use Windows Bootloader (Don't ask me why and tell me how lilo and grub are better i just want ) but the problem is that when i follow the instructions used in Mandrake and RedHat (and worked) nothing seems to happen.

    I mount the /dev/hda4 partition using Knoppix Live Cd and do:
    mount -t msdos /dev/fd0 /mnt/floppy
    dd if=/dev/hda4 of=/mnt/floppy/linux.bin bs=512 count=1
    umount /mnt/floppy/

    This writes a file linux.bin on the floppy but when i open it with notepad in windows its empty!!!

    As i said before this worked using mandrake and redhat with the bootloader installed on the /dev/hda4 partition.

    What am i doing wrong? Does anyone know how to make this work without installing a linux bootloader in MBR (again i don't want to do this and i don't want to install it and later remove it using fixmbr - i've had bad times with this one to many times)

    Could it be the fact that i installed grub as a bootloader in /dev/hda4 instead of lilo although being experimental in Yoper?

    I also never used reiserfs as the filesystem before. I always used ext3.

    Thanks for all your help.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    You ought to look into creating a boot floppy to boot to GRUB and then to your Linux. I haven't yet found how to make a floppy with the splashscreen menu, so you may be stuck with manually entering the required input in GRUB each time you boot. Something like this:
    Code:
    root (hd0,3)
    kernel /(yourkernel) ro root=/dev/hda4
    initrd /(yourinitrd)
    Otherwise, if you really want to use the Windows boot loader to start Linux, you can try sending a polite e-mail to Mr Gates in Redmond, Washington, c/o Microsoft and then wait patiently for a reply.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •