Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I'm new to Linux and new to this forum as well. I've started to play with Linux for a while, and I'm thinking about programming with it. In this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2011
    Posts
    5

    Software Installation Dependency issues


    Hi,

    I'm new to Linux and new to this forum as well. I've started to play with Linux for a while, and I'm thinking about programming with it. In this course, I tried to install Bochs from debian package but when I try to install it with synaptic package manager, it gives lots of dependencies error. I downloaded some of the dependency packages as well but it seems as if there are lots of them. So far I've resolved 30 of the dependency errors but I'm somehow exhausted downloading every single package.
    Isn't there a way to download the complete debian package or some way to automatically install dependent package as well? I'm desperately looking for help.

    I'm running Mepis Linux (kernel version 2.6.15-26-386).
    If you need anymore info, just ask and it'll be here.

    Thanks in advance.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,627
    It has been my experience that Synaptic (The front end for apt-get) resolves dependencies on its own. If you choose to install a package, it finds and installs all the needed dependencies for you. Did it not do this when choosing to install Bochs?
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Mar 2011
    Posts
    5
    Thanks for replying.

    Well it didn't do that. The linux distro I'm running is 5 years old, which might be one of the possible causes. I tried installing GCC and GNU LD as well, but I got similar result. I'd to install several dependent packages individually which was more than troublesome. I can't go on forever like this. I'm looking for a way out.
    Any ideas? Will switching to new Linux helps? Even then, it'd help to know if there's a workaround for this.
    Thanks.

  4. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Can you post the contents of the file /etc/apt/sources.list. I'm not sure with Mepis, but there might be other apt config files under /etc/apt.d/, include those if so.

    My guess would be it's pointing somewhere that no longer exists, if you're using a 5 year old release. Speaking of, why not use a current, maintained distro?

  5. #5
    Just Joined!
    Join Date
    Mar 2011
    Posts
    5
    Well, may be I should just dump this old distro and grab a new one.

    My Linux System is currently down and will take a while to work. Once done, I'll post the contents of both /etc/apt/sources.list and /etc/apt.d/, if I manage to find them. Will you please elaborate what these files are, so that I could be more specific with them?
    Thanks again.

  6. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The sources.list file is what the Debian package manager reads to determine where to look for downloading packages. It'll contain a number of lines like
    Code:
    deb http://ftp.nl.debian.org/debian/ stable main contrib non-free
    So it indicates the package repository mirror site, the release, ie, stable, testing, or unstable (this can also be code names for releases, lenny, squeeze, etc.), and the sections, main, contrib, and non-free.

    For unsupported releases, these mirrors are moved to an archive.

    I would assume given the old Mepis version you're using (which is based on Debian), the default mirrors will be pointing to the wrong locations and need to be adjusted to the archive mirror.

    /etc/apt.d/ is a directory. Sometimes, Debian-based distros might have their own software repositories with custom packages, and these would usually be listed under that directory or under /etc/apt/sources.list.d/. Actually, now that I look, I think the latter is more standard. The debian-based distro Crunchbang Linux, for example, has a file at /etc/apt/sources.list.d/crunchbang.list.

  7. #7
    Just Joined!
    Join Date
    Mar 2011
    Posts
    5
    Now everything makes sense.

    First, I downloaded each package manually from the Internet. I don't have an working Internet Connection with my Linux System. I think this is the root of the problem. If I'd let Synaptic Package Manager to download the package for me, it would have resolved dependency issues but since I didn't have working Internet Connection under my Linux System, I was obliged to download individual packages and then later install with Synaptic Package Manager.

    Thanks for being clear. I may feel like being obsessive, but is there anyway I can download whole the Bochs package manually and later install it with Synaptic Package Manager, resloving dependency issues, thereby?
    Or should I download each dependent package one by one and again, install each package one by one?

    Thanks in advance.

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    There is another way to download packages and all its dependencies in other machine and install those in your machine.
    Let say, you want to install abiword, a word processing package.
    Execute this in Terminal
    Code:
    sudo apt-get -qq --print-uris install abiword | cut -d\' -f 2 > urls
    less urls
    * Copy urls file to machine having Internet connection.

    * Open urls.txt file in Windows machine and download every package listed in it. You can use any Download Manager to automate this process.

    * Copy packages and save in /var/cache/apt/archives folder.

    * Execute this in Terminal to install package :
    Code:
    sudo apt-get install abiword
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Mar 2011
    Posts
    5
    I tried, but it bumps out with this error:
    E: Couldn't find package Bochs

    Moreover, if I replace Bochs with abiword, it reports:
    E: Package abiword has no installation candidate

    Is something wrong?

    And, one more question:
    My Linux Distro DVD has lots of packages in it. When I try to install them, it gives me similar dependency errors. Can this be resolved? Will copying whole the packages to /var/cache/apt/archives and then executing sudo apt-get install package work?

    Sorry for lots of questions. Thanks for reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •