Find the answer to your Linux question:
Results 1 to 4 of 4
Hello All Yoperators, This is my first experience with Yoper and the 2.6 Kernel. I am a Debian/Slackware user but wanted to try something a bit defferent on my new ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15

    Linksys WPC11 v.3 WiFi


    Hello All Yoperators,

    This is my first experience with Yoper and the 2.6 Kernel. I am a Debian/Slackware user but wanted to try something a bit defferent on my new laptop, Dell Inspiron 9100, 3.0 GHz P4, 512MB RAM, .

    As the title sugests I have a linksys WPC11 v3 Wireless card. This one uses the orinoco_cs driver or at least it is the one I have used in the past. I can't get it to work.

    I have tried modprob orinoco_cs but yoper complains about can't find ....../lib/modules/2.4......

    When I lsmod nothing shows up.

    Any suggestions ?


    Thanks,

    Norm


    One last thing, I am using it via the PCMCIA slot, so it ian After Market card.

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    Netherlands
    Posts
    9
    Hi ...

    Well the driver should be installed in
    /lib/modules/"kernel-version"/kernel/drivers/net/wireless/
    in my case "kernel-version"=2.6.7-6

    when you are in this directory .. you can do ls
    and see what drivers there are ...

    it shows in my directory listing lots of orinoco drivers ....

    well here is my listing anyway ..

    username@localhost wireless $ ls
    airo_cs.ko atmel.ko orinoco_cs.ko orinoco_tmd.ko wavelan_cs.ko
    airo.ko atmel_pci.ko orinoco.ko prism54 wavelan.ko
    arlan.ko hermes.ko orinoco_pci.ko ray_cs.ko wl3501_cs.ko
    atmel_cs.ko netwave_cs.ko orinoco_plx.ko strip.ko

    as you can see your driver is listed there too ...

    it is a bit strange that you get an error reporting can't find /lib/modules/2.4.......... while running a 2.6 kernel ...

    anyway to load this module automatically that you need ..
    put it in the file /etc/init.d/local e.g. like i put it in below


    ******* beginning of file /etc/init.d/local ***********

    #!/bin/bash

    source /etc/init.d/functions

    case "$1" in
    start)

    # added modprobe parport_pc after having problems installing parallel printers
    # discovery parport_pc needs to be loaded before daemon cupsd starts
    # manually this can be achieved as follows
    # killall cupsd
    # modprobe parport_pc
    # cupsd
    # this way parport_pc is loaded before cupsd is started
    # this is because the local startup script /etc/rc.d/init.d/local
    # is executed before the script /etc/rc.d/init.d/cups
    # so putting modprobe parport_pc into local achieves what we wants
    modprobe orinoco_cs
    modprobe parport_pc
    modprobe apm 2&>/dev/null
    #fix possible /tmp problem
    rm -rf /tmp/* >/dev/null 2>&1
    rm -rf /tmp/.* >/dev/null 2>&1
    rm -rf /var/cache/apt/archives/*rpm >/dev/null 2>&1
    chmod -R 777 /tmp
    chmod +t /tmp
    chmod -R 777 /proc/bus/usb/

    ;;

    stop)
    echo
    ;;

    restart)
    $0 stop
    sleep 1
    $0 start
    ;;

    *)
    echo "Usage: $0 {start|stop|restart|}"
    exit 1
    ;;
    esac

    ******* end of file /etc/init.d/local ***********


    if it still points to /lib/modules/2.4 check if modules for 2.6 do exist ..
    if they do exist point to the modules of 2.6 kernel directly ..
    by doing modprobe /lib/modules/......./orinoco.cs or something like that .. well ... this is what i would try ... i have not had such a problem before .. if it persists try and ask andreas about it in official yoper forums if they do come online again ... i hope they do ... ok good luck ..
    i hope you find out what is wrong ..

    Greetings

    Jellus

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Thanks Jellus for your help. I tried what you said and I think it would have worked but yoper is still looking for /lib/modules/2.4~ for some reason. That is my problem and I think if I fix that it the system should work fine after that.

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Well I just decided to reinstall it. That cleared it up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •