Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all I installed yoper this week end. This linux looks quite good I am having a problem in using my Epson Perfection 1260 scanner. I would like to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2

    Changing permissions for scanner


    Hi all

    I installed yoper this week end. This linux looks quite good
    I am having a problem in using my Epson Perfection 1260 scanner.
    I would like to use the iscan backend provided by Epson.
    I installed the .rpm file and the scanner works but only as root.
    I am trying to give all users the necessary permissions to use the scanner.
    I have not yet succeeded in doing this.
    As the scanner uses libusb and hotplug the device should change every time it is disconnected and reconnected.
    I tried creating a script to give all users the necessary permissions, as explained on http://khk.net/sane/libusb.html.
    That script is not working. But I don't have much experience with shell scripting... Any suggestion is appreciated.
    Does anybody know another way to give all users the right permission to access the scanner?
    This is the only problem I have to solve to end the configuration of my Yoper system, and, so far, everything went very well.
    I don't want my girlfriend to use the root password every time she needs to use the scanner

    Thank you

    Antonluigi (Italy)

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Open up /etc/udev/permissions.d/50-udev.permissions in your fav. editor (*cough* vim *cough*) and look for the device that corresponds to your scanner. Make it owned by the group users and give it 0660 permissions. The entry will look roughly like this:

    Code:
    usb/scannerdevicehere*:root:users:0660
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    I tried this way. It doesn't work.
    If I am not wrong the scanner is not seen as scanner*
    the command sane-find scanner reports it is connected at libusb:004:00x.
    What device it that?
    I can find it in /proc/bus/usb/devices/004 but it is not a /dev.
    Could you please explain better what you suggested?
    May be I didn't understand correctly

    Thanks anyway for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •