Find the answer to your Linux question:
Results 1 to 9 of 9
Hi I bought a HP laptop about 2 years ago and it was getting really buggy and slow so i deiced to reinstall it, so i put linux Pardus 2011.1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2011
    Posts
    4

    Pardus 2011 Missing Operating System


    Hi

    I bought a HP laptop about 2 years ago and it was getting really buggy and slow so i deiced to reinstall it, so i put linux Pardus 2011.1 on. I put the cd in and rebooted, i formatted the disk and installed the OS, when it had finished i tried to reboot and striaght after the HP splash screen it said "Missing Operating System"

    No other messages. I ran a memory check, both RAM and th HDD are working. I tried putting the Pardus cd and rebooting again, same message, i tried the windows cd that came with the laptop and still same message, i tryed going in to BIOS and changing the boot order, but the CD was already at the top. I went in to the boot up menu and selected "other" and still nothing, and ive tried booting from the HDD

    My laptop is the HP Compaq Presario CQ40-512TU
    S/N CND924325B
    P/N VFO58PA#UFF

    If some one can help that would be fantastic
    Thanks
    Ben

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,966
    Missing Operating System" Error Message Appears On Black Screen

    Try HP site. Maybe Bios is not recognizing anything

    https://h10025.www1.hp.com/ewfrf/wc/...&product=95681

    Maybe try a Puppy Live cd also and see if it will boot as a live session. I will be surprised if dvd drive and hardrive and bios all went bonkers at the same time also.

    Edit: Might try a cmos reset also. By pulling cmos battery and re-seating it again.

    Your manuals from HP
    Last edited by rokytnji; 09-11-2011 at 04:42 PM.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Sep 2011
    Posts
    4
    That what i though and i found that site before and i tested the HDD but i can do steps 2 and 3 because i cant boot from the cd drive, and when i try to contact hp they tell me my warranty has expired and send me to that same page ive been going round in circles all day

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,966
    I edited my post above to give you links for HP manuals. You might try a cmos reset which will bring the bios back to stock condition. Hard to troubleshoot this over the net as it looks to be a hardware/bios problem.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,966
    Screw that. if your CQ40 is anything like this image for a CQ60 on cmos battery location. It is too many hoops to jump through doing a cmos reset . My cmos battery sits right under the laptop battery on my IBM. I don't know what HP was thinking putting the battery in the image below location.



    Link I got image from How to disassemble HP G62 or Compaq Presario CQ62 laptop >> Inside my laptop

    Previous address to get the above link from
    Repair4Laptop: How to Upgrade, Repair, Disassemble a COMPAQ Laptop or Notebook

    Out of ideas here, sorry
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    If you can't get the system to boot with any LiveCD or the Windows CD/DVD's then you probably need to replace the CD/DVD drive itself. Just to check, try the boot CD/DVD on any other machine, if they work on the other machine but not yours then the drive is toast.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Just Joined!
    Join Date
    Sep 2011
    Posts
    4
    The Cmos battery was fairly east to get to, i unplugged it for a bit and put it back in but still same problem

    the cd drive still spins up and was working perfectly fine and is recognized by the bios, and even if it was broken i dont see how it would stop a hard drive boot.

    can i do a boot by a USD thumb drive? just a thought

  8. #8
    Just Joined!
    Join Date
    Sep 2011
    Posts
    4
    problem solved

    I booted up from puppy live and deleted the partition and started again with pardus

    Thanks for you help

  9. #9
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I know I'm a little late on this one, but Missing Operating System can sometimes just be an issue of your bootloader looking in the wrong location for the / partition. For example, GRUB may have been pointing to sda1 while / was mounted to sda2.

    Just something to look for if it ever happens again.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •