Find the answer to your Linux question:
Results 1 to 5 of 5
Has anyone at all managed to get yoper to work with kernel 2.6.9? I have tried it various times, but when i reboot it complains that is cannot detect my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    17

    yoper and Kernel 2.6.9


    Has anyone at all managed to get yoper to work with kernel 2.6.9?

    I have tried it various times, but when i reboot it complains that is cannot detect my / partition or that their is a problem with it.

    my / partiiton is formatted in reiserfs which i have compiled into the kernel, so i don't know what the problem is as 2.6.8.1-7 works just fine.

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Posts
    17
    hmm. after a fresh install i've tried this again with the 2.6.9 kernel (now nitro sources patched) and still no luck.

    upon boot i get a message saying:

    ####an error occured during the file system check
    ####dropping you to a shell


    From there i can give my root password and gain readonly access to the system. It no seems the error is on /dev/hda6 which has been reformatted in reisferfs now (as i thought it may have been reiser4 giving me the problems last time).

    if i try #reiserfsck /dev/hda6 i get an error saying that is cannot open the device.

    is this just a problem with Yoper? (when i ran gentoo the 2.6.9 worked fine)

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Did you perhaps format it in reiser4? Also you may have forgotten support for your chipset. Without this, yoper wouldn't be able to see any of your disks or partitions.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    17
    er no it is formatted in reiserfs it was previously formatted in reiser4, i now that for a fact as if i had it wrong in the fstab then the other kernels wouldn't boot. Support for my chipset is also compiled into the kernel.

    Like i said this problem has only happened on yoper using the vanilla 2.6.9 kernel.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    New Zealand
    Posts
    20
    I would suggest investigating what patches the yoper team added to the vanilla 2.6.8 kernel, it might be a reiserfs version mismatch. mixing versions of reisrefsprogs / kernel drivers can have kinda unpredictable results. (I hosed a disk like that)
    Does your chipset have any bugfixes in the kernel? are they enabled? tried disbling hdparm / dma?
    How did you compile the new kernel? I would do a make oldconfig
    on the .config from the yoper kernel...
    Is your initrd set up properly?
    I would get the SRPM for the latest yoper kernel an looking at what patches have been used... but I can't afford an ~80mb download right now.


    Steve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •