Find the answer to your Linux question:
Results 1 to 5 of 5
It's based on Debian and Ubuntu and very lightweight, perfect for my laptop, but I can't run any configure installers because there's no c compiler. How do I get a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    32

    just installed Masonux, no c compiler


    It's based on Debian and Ubuntu and very lightweight, perfect for my laptop, but I can't run any configure installers because there's no c compiler. How do I get a c compiler installed, when the installer for the compiler itself needs a c compiler? Does anyone have gcc already installed and can send me the directory structure and a tarball?



    - Edward

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,053
    Connect to the internet.

    Open a terminal

    Code:
    apt-cache policy build-essential
    It will give version number and tell you it is not installed.

    To install build-essential (you need internet connection for the rest of comands given)

    Code:
    sudo apt-get update
    Hit enter key: Then type in password (it will not show anything when typed in). Hit enter key. Let it finish updating packages.Then install build-essentials with the command

    Code:
    sudo apt-get install build-essential
    build-essential does not come installed in any Debian based or Ubuntu based distro by default. You need to install it from your repositories off the net.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Posts
    32
    Thanks, I will try that.

  4. #4
    Just Joined!
    Join Date
    Nov 2010
    Posts
    32
    It looks like since I posted my question, since I updated my sources.list file, which in this distro comes with nothing newer than Ubuntu Jaunty sources, to Lucid, and then also added some Debian Repos, that the build-essentials had been installed already. I can't seem to find the compiler file though, because it needs to be added to the PATH variable. I need I tried to reinstall it anyway though and alas it gave me 4 upgrades. Hopefully this will make it work,

  5. #5
    Just Joined!
    Join Date
    Nov 2010
    Posts
    32
    Okay looks like it worked. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •