Find the answer to your Linux question:
Results 1 to 2 of 2
SO, I am attempting to flash Snake-OS to a NAS device through serial, Uboot doesn't give me an option to flash directly (I don't think) but I do have all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    2

    an absurdly simple question....(not really)


    SO, I am attempting to flash Snake-OS to a NAS device through serial, Uboot doesn't give me an option to flash directly (I don't think) but I do have all these fancy options:
    Code:
    autoscr - run script from memory                                                
    base    - print or set address offset                                           
    bdinfo  - print Board Info structure                                            
    boot    - boot default, i.e., run 'bootcmd'                                     
    bootd   - boot default, i.e., run 'bootcmd'                                     
    bootm   - boot application image from memory                                    
    bootp   - boot image via network using BootP/TFTP protocol                      
    cmp     - memory compare                                                        
    coninfo - print console devices and information                                 
    cp      - memory copy                                                           
    crc32   - checksum calculation                                                  
    echo    - echo args to console                                                  
    erase   - erase FLASH memory                                                    
    flinfo  - print FLASH memory information                                        
    go      - start application at address 'addr'                                   
    help    - print online help                                                     
    iminfo  - print header information for application image                        
    imls    - list all images found in flash                                        
    itest   - return true/false on integer compare                                  
    loadb   - load binary file over serial line (kermit mode)                       
    loads   - load S-Record file over serial line                                   
    loop    - infinite loop on address range                                        
    md      - memory display                                                        
    mm      - memory modify (auto-incrementing)                                     
    mtest   - simple RAM test                                                       
    mw      - memory write (fill)                                                   
    nfs     - boot image via network using NFS protocol                             
    nm      - memory modify (constant address)                                      
    pci     - list and access PCI Configuration Space                               
    printenv- print environment variables                                           
    protect - enable or disable FLASH write protection                              
    rarpboot- boot image via network using RARP/TFTP protocol                       
    reset   - Perform RESET of the CPU                                              
    run     - run commands in an environment variable                               
    saveenv - save environment variables to persistent storage                      
    setenv  - set environment variables                                             
    sleep   - delay execution for some time                                         
    tftpboot- boot image via network using TFTP protocol                            
    version - print monitor version
    I've read the documentation for Uboot and figured out how to set up a tftp/DHCP server and boot my kernel, I just want to make sure I don't miss anything and screw this thing up. and even easier I have a kermit script to use the loadb option, all I need to do is input the right memory address to send the .bin to (thats IF I understand all this correctly)

    I let the kernel boot and saw this:
    Code:
    STR8100 SPI: init                                                               
    m25p80 spi1.0: m25p128 (16384 Kbytes)                                           
    Creating 9 MTD partitions on "m25p80":                                          
    0x00000000-0x01000000 : "U-Boot"                                                
    0x00020000-0x00140000 : "Kernel"                                                
    0x00140000-0x00640000 : "RootFS"                                                
    0x00640000-0x00ac0000 : "Config"                                                
    0x00ae0000-0x00be0000 : "Kimage"                                                
    0x00be0000-0x00ea0000 : "Rimage"                                                
    0x00ea0000-0x00f80000 : "Cimage"                                                
    0x00f80000-0x00fa0000 : "u-boot-env"                                            
    0x00fa0000-0x00fc0000 : "dev"
    So I assume 0x00020000 is the memory address I want to send the .bin, I am pretty Damn new to linux and I know this is simple, "Right there in front of your face dumbass" you're probably thinking but like I said, I just want to make sure... So no flames please. Any help will be greatly appreciated I don't really want to be spoonfed...


    SOLVED, I was scared to touch certain things, but when I type loadb I got this output (and my answer):


    Ready for binary (kermit) download to 0x00800000 at 38400 bps...
    Last edited by Sp00nfed; 04-02-2012 at 09:02 PM.

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    2
    ok, so maybe not solved after all....everything goes smooth then on reboot the same tired old kernel loads, any thoughts? my first thought is thats the wrong memory address, not too sure though...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •