DD-WRT v24-sp2 (01/02/10) std-nokaid - build 13577M NEWD-2 Eko

Need help with this issue....

I am trying to install lighttpd on my dynex router so i do not need a dedicated www server for my site...

first i enabled Jffs, and used the tutorial on expanding jffs space with a samba mount, and successfully mounted it to /jffs/, i can see the new space in the ssh consol.

secondly i cd /jffs , and did a ipkg update , and that was also successfull...

thirdly I did a Install lighttpd, libpcre and libopenssl said "expanding.... done" then "configuring...done" Then when it tried to install lighttpd it said depandants not installed "libpcre libopenssl" and it failed

so Forth step i did a "ipkg -force-depends intall lighttpd" it install successfull but with warning for "libpcre and libopenssl"

5th I check /jffs/usr/sbin and lighttpd exists so i try and start it, and i get "/jffs/usr/sbin/lighttpd: can't load library 'libpcre.so.0'"

6th I checked to make sure that libpcre exists, and it dose in the /jffs/usr/lib dir, and both libopenssl and libpcre are there.

7th I created a symlink in /opt/lib/ using lm -s /jffs/usr/lib/libpcre.so.0.0, tried to run lighttpd again same error...

8th I checked the eviroment varabalss with "env | grep LIBRARY, and i get this:
LD_LIBRARY_PATH=/lib:/usr/lib:/jffs/lib:/jffs/usr/lib:/jffs/usr/local/lib:/mmc/lib:/mmc/usr/lib:/opt/lib:/opt/usr/lib

I am assuming that the /jffs/usr/libs is linked correctly, but i staill get same error when loading lighttpd.

Someone please help, i am assuming that libpcre is corrupt or something.... is there another version of this file i can use?? or dose anyone have any other suggestions