Find the answer to your Linux question:
Results 1 to 7 of 7
Hi everybody. I desperately need help , since I'm pretty new to the linux world. I've built a mini pc for the music and I've installed linux voyage that is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5

    ndiswrapper and wifi problems (linux voyage)


    Hi everybody.
    I desperately need help , since I'm pretty new to the linux world.
    I've built a mini pc for the music and I've installed linux voyage that is a very light debian distro, specifically made for the music servers.

    My wifi pen is a gigaset usb stick 108, that has only windows drivers. This is why I have to use ndiswrapper.
    I've encountered problems with ndiswrapper from the beginning, since I had to install it with "make install", instead of the more simple "apt-get".
    Now it runs at startup only because I've written "ndiswrapper" in /etc/modules, in "rcconf" doesn't even appear.

    The problem is that everytime I boot the pc I have to digit "ndiswrapper -m", "modprobe ndiswrapper", go to wicd-curses and search for the access point, then it finally connects to it.
    Obviously it should connect automatically at the startup.

    Can someone help me, please?

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Welcome acvtre!

    You could put the commands in /etc/rc.local... something akin to this:
    Code:
    ndiswrapper -m
    /sbin/modprobe ndiswrapper 
    /sbin/iwconfig wlan0 essid youraccesspoint 
    rm /etc/dhcpc/*.pid   
    /sbin/dhclient wlan0
    Or something along those lines.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    Quote Originally Posted by Dapper Dan View Post
    Welcome acvtre!

    You could put the commands in /etc/rc.local... something akin to this:
    Code:
    ndiswrapper -m
    /sbin/modprobe ndiswrapper 
    /sbin/iwconfig wlan0 essid youraccesspoint 
    rm /etc/dhcpc/*.pid   
    /sbin/dhclient wlan0
    Or something along those lines.
    Thank you so much for the reply. I'm a real noob, so I need precise indications, please. How can I find the exact name of the file to modify? /etc/rc.local...(what I wright here?).
    Then, I've configured wicd-curses in order to have a static IP, so I suppose I don't need the last 2 lines, right? Or using those 2 lines I don't need wicd-curses?

    Thanks.

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    I think this method will work for you too. It's for Ubuntu but both are Debian so I think it's worth a try. It probably is a better way to do what you want. Having said that, I'm totally unfamiliar with your distro so what have you been using to edit files? If you open a terminal and put the command for your editor in followed by /etc/rc.local your editor will open it. You'll need to do this as root. Here's my rc.local for a little context...
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    exit 0
    So you'd edit it to look something like this:
    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    ndiswrapper -m
    /sbin/modprobe ndiswrapper 
    /sbin/iwconfig wlan0 essid youraccesspoint 
    rm /etc/dhcpc/*.pid   
    /sbin/dhclient wlan0
    
    exit 0
    This should get you an assigned IP from your access point and won't be static. Try leaving the last two lines off and see if the other gives you a static IP. Just reboot to get it to take effect once you have the parameters filled in for your situation. After booted up, you can check to see if you are connected with /sbin/iwconfig wlan0 or whatever your device name is, then bring up the interface like you've been doing.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    To edit files I use "nano".
    However, I use wicd-curses to manage the network and I suppose there's a problem about the timing, but I don't know what do I have to wright in rc.local to boot wicd.
    I suppose I need to wright something like:
    #/sbin/ndiswrapper -m
    /sbin/modprobe ndiswrapper
    sleep 2
    (command to start wicd-curses)#


    Moreover I'm not sure this is the real problem, because I have to detach and reattach the wifi pen to let it recognize properly to the SO.
    Last edited by acvtre; 04-23-2012 at 02:33 PM.

  6. #6
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    Ok, I've practically found the problem, I suppose. At the first boot the wifi pen is correctly loaded and connected to the internet, but if I reboot it doesn't get loaded, this means that it starts only with the cold boot. Why?

    I use grub as bootloader, how can I set it to reboot always as a cold boot?

    Another question: how can I put the access point password in /etc/network/interfaces? What do I have to wright to access the access point with the proper password?
    Last edited by acvtre; 04-25-2012 at 08:10 PM.

  7. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Glad you're getting this sorted. Have a look at this.
    Linux Mint + IceWM Registered:#371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •