Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I am currently working on moving my centos 6.3 over from my old computer to my new computer with new hardware. Basically I imaged the Hard drive with Acronis ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2

    Problem loading centos 6.3 after moving to a computer with new hardwar


    Hi,

    I am currently working on moving my centos 6.3 over from my old computer to my new computer with new hardware. Basically I imaged the Hard drive with Acronis Workstation 11 and restore the image to my new Hard drive in my new computer. Currently when I put either hard drive in I get the grub loader, than the CentOs 6.3 loading bars followed with a black screen with a blinking cursor. Currently I have tried both hard drives in the old system and they work flawlessly.

    What I have tried in the new system in doing a system rescue on the loaded OS. Which found the OS and set it to boot. After the restart it starts and says that it needs to do relabeling which afterwards it reboots. Than I am back to the Black screen with a blinking cursor after Centos 6.3 loading bars.

    Could anyone suggest to me how to fix this problem? Thanks for all that read this and for anything you can suggest I try next.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hello and welcome!

    The first thing I would try is rebooting with the graphical boot stuff turned off, so that you are sure not to miss any important messages from the kernel or init process. Reboot and at the grub prompt, highlight your kernel of choice and press the "e" key to edit the kernel entry, then on the kernel parameters line, remove the portion of the arguments that read "rhgb quiet". Then boot and see what it says.

    The second thing I'd try is reinstalling grub. Try this guide on how to do that:

    TipsAndTricks/ReinstallGRUB - CentOS Wiki

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2
    Hi I have tried finding the rhgb quiet as you said inside the kernel entry with no success. I than tried reinstalling the grub with the CentOS-6 pick "Rescue installed system" from the boot menu. I than did the # chroot /mnt/sysimage followed by # grub-install /dev/sda since it is on my sata drive. This is the only sata drive hooked to the computer at the moment. I than reboot. It goes thru the SELinux targeted policy relabel as required. Once it finishes that it reboots hits the grub, I select the OS entry for 6.3. It continues thru to the Centos 6.3 loading bars the three on the bottom, after the bars fill up I am back to a black screen with a blinking cursor. Let it sit there for a hour with no change. Any other suggestions. Thanks for all you have done in helping me with this.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Okay, show the output of these commands:

    Code:
    cat /proc/cmdline
    and as root:
    Code:
    cat /etc/grub.conf
    or if that file does not exist:
    Code:
    cat /boot/grub/grub.conf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •