I am sure there are 100's of tuts out there explaining how to fix this. No actually I know for a fact there are, because I have tried nearly all of them..
I have an ATI Radeon HD 5700, 8.892.0.0(Driver version)
Trying to run a Live CD install with BT5R3 GNOME.
I have already used this OS on VM, so that may or may not be a problem, that's why I am here.

This is pretty much how it goes,
I boot up, get to the tab screen, press it, (have tried changing the line by adding
xforcevesa noapic noapci nosplash irqpoll -- after initrd.gz
) hit enter, does the loading it should, then either shuts off my keyboard at the bt5 screen (Failing to use the ports, apparently. I cannot remember the exact error) or it blank screens me, and does not detect my monitor anymore. (HDMI NO SIGNAL)
It is also important to point out, that I am trying to dual boot windows 7 and Backtrack 5 r3.



SYSTEM INFORMATION
OS Name Microsoft Windows 7 Ultimate
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name BELKIN
System Manufacturer Gigabyte Technology Co., Ltd.
System Model GA-970A-UD3
System Type x64-based PC
Processor AMD Phenom(tm) II X4 955 Processor, 3200 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date Award Software International, Inc. F1, 5/17/2011
SMBIOS Version 2.4
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume4
Locale United States
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name BELKIN\Jobes
Time Zone Central Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 8.00 GB
Available Physical Memory 5.89 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 13.3 GB
Page File Space 8.00 GB
Page File C:\pagefile.sys
Thanks,

Kodeki
/wave