Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Hey all, been having a bit of a dilemma trying to get a usable ssh server running on my puppy install, puppy arcade in particular. Seems to be little to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    16

    SSH Server for Pup


    Hey all, been having a bit of a dilemma trying to get a usable ssh server running on my puppy install, puppy arcade in particular. Seems to be little to nothing available and what is out there is old as dirt. I'd like something with some sort of gui but just as a luxury, its not really necessary. Found what looked like a few nice custom builds of openssh v5.2 but most of the links seem broken.

    I've previously installed openssh v5.1 but having a heck of a time getting it to work properly as my ssh client can never seem to connect and that still leaves the issue of getting it to boot on startup as well as setting all the desired security options.

    If anyone knows a better solution thanks for the input.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hey,

    what version of Puppy is your version of Arcade based on? From what I've read, it is Puppy 4.2. If so, have you tried the openssh-5.1p1-SSHD+Dev package in the official pet repos here?

    Index of /puppylinux/pet_packages-4/

    as to starting it up at boot time, have you tried adding a call to the sshd binary in the file /etc/rc.d/rc.local?

    as to version 5.2, you could try the one here, if you are inclined to trust the source. i see that inside the file, there is an sshd start-up script (not tested).

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    16
    Yes i believe 4.2 is correct. I had not seen the ssh server in the repos so thanks for pointing that out. Last time I set up openssh it on my Debian setup it ran fine out of the box. Hopefully, I'll have more success thanks to your advice.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    good luck, and be sure to post back what combination of ssh package and configurations ends up working for you, so future visitors may benefit.

  5. #5
    Just Joined!
    Join Date
    Sep 2009
    Posts
    16
    OMG, I am so annoyed and frustrated. I've been trying for 2 freaking days to get a working sshd in Puppy and I am no closer now then I was before. I've installed the sshd package but now what? I found the ssh on the hard drive but its a binary and when I try to start it it says 'Privilege separation user sshd does not exist. There doesn't seem to be a groupadd or even an adduser in Puppy and I am reading what sounds like Puppy is really designed for only one user. I could disable the user in the config but I don't want to sacrifice security, which is actually a joke because lack of knowledge and understanding make me the kind of user that is every hackers dream. I just want a working sshd so I can work on the machine from my main desktop instead of turning to the side all the time to key in commands and it has turned out to be so impossibly difficult. Every tutorial I read, I run into problems not specified. I don't even know where things got installed to or what's left over from the last install of sshd. The last install seemed to put things in different places then this current version I installed through the package manager. There are probably some remnants of the last version still floating around. Why does everything have to be so darn difficult?

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Is there an rc init script, in the /etc/init.d/ directory, by chance? usually, you can call it like this:

    Code:
    /etc/rc.d/rc.sshd start
    but it may be slightly different than that. see this thread for what appears to be a successful implementation of openssh 5.1 on puppy 4.2.

    i don't have Puppy installed, so I can't replicate your situation unfortunately. However, hopefully someone here can help, provided that you provide the necessary details. To that end, if/when you post back, please include exact commands you run, and any errors you get in the console.

    if you want to list the contents of a pet file, to try to determine what has been installed (so that you can remove it, etc.), try this:

    Code:
    cat openssh-x.xx.pet|gunzip > openssh-x.xx.tar
    mkdir openssh-x.xx
    cd openssh-x.xx
    tar xf ../openssh-x.xx.tar
    now all the contents of pet file "openssh-x.xx.pet" will be in the current working directory, complete with all subdirectories.

  7. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by rfxcasey View Post
    Privilege separation user sshd does not exist. There doesn't seem to be a groupadd or even an adduser in Puppy and I am reading what sounds like Puppy is really designed for only one user.
    my curiosity got the better of me and I installed Puppy Arcade 10 to a VM. I managed to get the ssh daemon installed and running. I installed the package itself using the graphical tool Puppy Package Manager by right-clicking the desktop and selecting Setup > Puppy Package Manager. then i clicked the button to browse the online PET repo. Making sure the All radio button is checked, i scrolled down to openssh-5.1p1-SSHD+Dev and clicked it to install. after a moment i got:

    Code:
    SUCCESS:  openssh-5.1p1-SSHD+Dev is installed!
    then i closed it. i can see the list of files installed with this command:

    Code:
    cat /root/.packages/openssh-5.1p1-SSHD+Dev.files
    when i tried to start sshd, i got the "privilege separation" error, too. i did this to install the required user:

    Code:
    addgroup sshd
    adduser -H -G sshd -h /var/empty -s /bin/false -D sshd
    make sure /var/empty is indeed a directory.

    then i could start the daemon:
    Code:
    /usr/sbin/sshd
    i could see it runing in ps and listening in "netstat -tulnp". i could not connect locally b/c of issues with the puppy linux ssh client, and my VM host can't connect to it b/c of VM network issues, but that is unrelated to the ssh daemon itself on puppy. so give that a shot.

  8. #8
    Just Joined!
    Join Date
    Sep 2009
    Posts
    16
    Ok so I did as you suggested. I had already previously created the group sshd. When I tried the adduser command with the options you specified I
    Code:
    addgroup sshd
    adduser -H -G sshd -h /var/empty -s /bin/false -D sshd
    returned that the login was already in use.

    I typed
    Code:
    ps
    and sshd is indeed running.

    I did
    Code:
    netstat -tulnp
    I read a post somewhere that suggested iptables might be blocking the port. I also would like to see if my sshd config file is the problem. Ill going to look into this. If you've any advice it would be helpful. And by the way I can FTP into the machine with no problem when running the ftpd and using Filezilla from my Windows machine.
    Here is my sshd config file:
    Code:
    #	$OpenBSD: sshd_config,v 1.80 2008/07/02 02:24:18 djm Exp $
    
    # This is the sshd server system-wide configuration file.  See
    # sshd_config(5) for more information.
    
    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
    
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented.  Uncommented options change a
    # default value.
    
    #Port 22
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::
    
    # Disable legacy (protocol version 1) support in the server for new
    # installations. In future the default will change to require explicit
    # activation of protocol 1
    Protocol 2
    
    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key
    
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 1024
    
    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO
    
    # Authentication:
    
    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6
    #MaxSessions 10
    
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile	.ssh/authorized_keys
    
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    
    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    
    # Set this to 'yes' to enable PAM authentication, account processing, 
    # and session processing. If this is enabled, PAM authentication will 
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication.  Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    #UsePAM no
    
    #AllowAgentForwarding yes
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no
    #ChrootDirectory none
    
    # no default banner path
    #Banner none
    
    # override default of no subsystems
    Subsystem	sftp	/usr/libexec/sftp-server
    
    # Example of overriding settings on a per-user basis
    #Match User anoncvs
    #	X11Forwarding no
    #	AllowTcpForwarding no
    #	ForceCommand cvs server
    Now here is something I though was a bit strange. When I am running PureFTPD and sshd at the same time, and I type
    Code:
    netstat -tulnp
    I get
    Code:
    PID/Program name
    tcp          0          0 192.168.0.115:58285          0.0.0.0:*          LISTEN
    4975/pure-ftpd (IDL
    tcp          0          0 0.0.0.0:21                        0.0.0.0:*          LISTEN
    4965/pure-ftpd (IDL
    tcp          0          0 0.0.0.0:22                        0.0.0.0:*          LISTEN
    4014/sshd
    I, for the life of me, still cannot connect to the ssh server with putty from my Windows machine. Very frustrating indeed. Perhaps I have a setting screwed up. When I do try to connect I get
    Code:
    Network Error: Software caused connection abort
    Last edited by rfxcasey; 07-20-2013 at 03:39 PM.

  9. #9
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    from another Linux machine, scan that port to see if it is open (i.e., if a firewall is blocking):

    Code:
    nmap -n -sP -p 22 <pup_ip_address>
    that should tell you it is either open/filtered, or closed.

    have you tried to ssh in locally?

    what user are you trying to connect as? is root permitted to log in, in the sshd_config file?

    are there any logs on the pup server? /var/log/messages and /var/log/secure are the places i'd check, though their puppy locations might be different than that (my puppy vm is not up right now)

    show the exact error command you get when you attempt to log in.

  10. #10
    Just Joined!
    Join Date
    Sep 2009
    Posts
    16
    My sshd is pretty much set to default. I've included it above and the 'permitrootlogin yes' is commented out. I don't know what it is default, I've extreme noob at this. I'll try to scan the port from my Windows box.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •