Find the answer to your Linux question:
Results 1 to 2 of 2
In the beginning, Red Hat begat Fedora and Cobalt. Cobalt begat CentOS. BlueOnyx is built on CentOS. While my problem occurs when running BlueOnyx, the problem could be caused by ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Location
    USA, Great Northwet
    Posts
    2

    Keyboard & mouse stop working when GUI starts


    In the beginning, Red Hat begat Fedora and Cobalt. Cobalt begat CentOS. BlueOnyx is built on CentOS.

    While my problem occurs when running BlueOnyx, the problem could be caused by any of its predecessors.

    Background:
    I have installed BlueOnyx / CentOS 6.4 on 3 computers this week. All are different make/model, different processors, different amounts of RAM. Two are 64-bit, one is 32-bit.

    The installations are from ISOs downloaded from the same BlueOnyx mirror, same day.

    The workstations are 2 common (but different) HPs and a Dell. All are recovering Windows machines that ran XP, and later 7, with no problems.

    The mice and keyboards are standard, run-of-the-mill USB devices.

    There is nothing cutting-edge about the hardware.

    The problem:
    As long as I run everything from the CLI, everything works well. But ... on each of those 3, as soon as the gui starts - whether Gnome or KDE, the keyboard and mouse stop working. The GUIs display fine. They even show the cursor (which can't be moved)

    The only way to get working again is to use Putty from a 4th computer and kill sessions or reboot.

    To install the GUIs I did the following steps:
    - do a complete install from CD
    - yum update
    - yum groupinstall "X window system"
    - yum groupinstall "Desktop" (or "KDE Desktop")

    I have reinstalled BlueOnyx several times trying to find a cause and/or solution, but to no avail.

    I assume there's a package to install or config file to tweak, but have no idea where to start.

    Additional info:
    - first thing I do on a Linux install is to tweak sudoers to enable wheel groupees to have more utility.
    - then I do updates and install packages.
    - then I create a "standard" user in the USERS group. Why? Root can't run a GUI, but wheel and user groupees can.
    - then I test the installation from the CLI
    - after all of that I test the GUI. That's when the problem occurs.

    In case you're wondering - I use BlueOnyx so that my site admins can administer their web sites without having to learn Linux. It's all they can do to get through the day without screwing up much in Windows. But I don't get to pick my site admins, so I work with the tools I have to keep them going without much intervention on my part.

    BTW, I don't care to discuss the merits of having a GUI on a server. I have 25+ years working from CLI on several types of systems, and nearly as many working with GUIs. I know why I need a GUI on these servers .... I just need help making a GUI - any GUI - run properly in this environment.

    Thanks for reading my rant and contemplating a solution.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,737
    Well, I use CentOS, RHEL, and SL (Scientific Linux) 6.4 on a number of machines, and have not seen this problem. Have you tried a direct CentOS or Scientific Linux 6.4 distribution on these machines?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •