Find the answer to your Linux question:
Results 1 to 2 of 2
I'm trying to get radvd running in a chroot enviroment, I was wondering if anyone has had any success in this and how they did it. radvd keeps exiting with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    8

    CHROOTING radvd


    I'm trying to get radvd running in a chroot enviroment, I was wondering if anyone has had any success in this and how they did it.

    radvd keeps exiting with "file permission on config file incorrect" I've tried all kinds of different combinations and the only information I found is it can't be writeable by world if running root, or it needs to be unwriteable for all i.e. 444 or 400 if running as non root.

  2. #2
    Just Joined!
    Join Date
    Jan 2011
    Posts
    8
    Did a little bit more reasearch, I had added the debug level to 5 and tried starting it, I don't think there is an issue with the file permissions now, it claims that there is no user "radvd" which is the usr I'm trying to have it drop permissions to while chrooting. If I tell it to drop to user radvd only it works fine, so there must be something missing from my chroot enviroment that maps users to names, and its not the passwd or group files. so I have no clue, whats missing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •