Find the answer to your Linux question:
Results 1 to 5 of 5
I'm running Centos 6.4 and I have configured the following interfaces with different ip addresses. However, for some reason the eth3 is always binding the ip address of eth0 when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2013
    Posts
    4

    Network interface binding wrong ip address


    I'm running Centos 6.4 and I have configured the following interfaces with different ip addresses. However, for some reason the eth3 is always binding the ip address of eth0 when doing a network restart or an ifup. How can I make eth3 use the correct ip address?


    eth0 Link encap:Ethernet HWaddr D4:AE:52:A4:80:F3
    inet addr:192.168.40.2 Bcast:192.168.40.255 Mask:255.255.255.0
    inet6 addr: fe80::d6ae:52ff:fea4:80f3/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:26320 errors:0 dropped:0 overruns:0 frame:0
    TX packets:194 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1630806 (1.5 MiB) TX bytes:18355 (17.9 KiB)
    Memory:da500000-da600000

    DEVICE="eth0"
    BOOTPROTO="none"
    IPADDR=192.168.40.2
    NETMASK=255.255.255.0
    GATEWAY=192.168.40.1
    NM_CONTROLLED="no"
    ONBOOT="yes"
    TYPE="Ethernet"


    eth1 Link encap:Ethernet HWaddr D4:AE:52:A4:80:F4
    inet addr:10.0.10.22 Bcast:10.0.10.47 Mask:255.255.255.240
    inet6 addr: fe80::d6ae:52ff:fea4:80f4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:10447860 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14763461 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3240198419 (3.0 GiB) TX bytes:1715786142 (1.5 GiB)
    Memory:da600000-da700000

    DEVICE="eth1"
    BOOTPROTO="none"
    IPADDR=10.0.10.22
    NETMASK=255.255.255.240
    NM_CONTROLLED="no"
    ONBOOT="yes"
    TYPE="Ethernet"


    eth2 Link encap:Ethernet HWaddr 00:0A:F7:0F:9C:BC
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:48 Memory:d7800000-d7ffffff

    DEVICE="eth2"
    BOOTPROTO="none"
    NM_CONTROLLED="no"
    ONBOOT="no"
    TYPE="Fiber"


    eth3 Link encap:Ethernet HWaddr 00:0A:F7:0F:9C:BE
    inet addr:192.168.40.2 Bcast:192.168.40.255 Mask:255.255.255.0
    inet6 addr: fe80::20a:f7ff:fe0f:9cbe/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3 errors:0 dropped:0 overruns:0 frame:0
    TX packets:49743 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:192 (192.0 b) TX bytes:2289913 (2.1 MiB)
    Interrupt:52 Memory:d8800000-d8ffffff

    DEVICE="eth3"
    BOOTPROTO="none"
    HWADDR=00:0A:F7:0F:9C:BE
    IPADDR=10.0.10.36
    NETMASK=255.255.255.224
    NM_CONTROLLED="no"
    ONBOOT="yes"
    TYPE="Fiber"

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    Check /etc/udev/rules.d/70-persistent-net.rules
    There may be entries in that file over riding your MAC to device mappings from your interface files.

  3. #3
    Just Joined!
    Join Date
    Nov 2013
    Posts
    4
    I don't see anything on this file that might be incorrectly over riding the MAC to device mappings:

    cat 70-persistent-net.rules

    # PCI device 0x8086:0x1521 (igb)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d4:ae:52:a4:80:f3", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    # PCI device 0x8086:0x1521 (igb)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d4:ae:52:a4:80:f4", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

    # PCI device 0x14e4:0x164f (bnx2x)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0a:f7:0f:9c:bc", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"
    # PCI device 0x14e4:0x164f (bnx2x)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0a:f7:0f:9c:be", ATTR{type}=="1", KERNEL=="eth*", NAME="eth3"

  4. #4
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    I'm not sure that type=fiber is a valid entry.

    13.2.*Interface Configuration Files
    This article talks about IPSec. I would put Ethernet there, if anything.

  5. #5
    Just Joined!
    Join Date
    Nov 2013
    Posts
    4
    The issue was first solved by recreating the eth 1 and eth3 using the gui utility under preferences. Then we came to the conclusion that was really causing the problem is having the NetworkManager running. We had to turn it off and then chkconfig off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •