Find the answer to your Linux question:
Results 1 to 10 of 10
I wrote a script to start ssh:Apache:mysql Placed it in the sys.int script. Launch the script and now I'm locked out. I need a floppy or cd where I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    I locked my shelf out.


    I wrote a script to start ssh:Apache:mysql
    Placed it in the sys.int script. Launch the script and now I'm locked out. I need a floppy or cd where I can get in and mount the partition and fix the sys.int file
    After you stop lol'ing any thought would be nice I need this server.......

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    You could download a live cd like Knoppix or Slax and boot it up, mout your Yoper drive, and then edit the sys.int script from there.

    check out www.distrowatch.org for were to download these live cd's.

    I'm not laughing btw

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I think you should be able to boot in "single" mode to fix it:
    http://www.linuxforums.org/forum/top...light=password
    /IMHO
    //got nothin'
    ///this use to look better

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    thanks for the other suggestion drakebasher, as always there are many different ways of doing things in linux, its just I'm rather fond of Slax...

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Sorry, dylunio. Notice, we have exactly the same time-stamp of 4:52
    /IMHO
    //got nothin'
    ///this use to look better

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    Thankx for the fast reply

    While boot I tried to press e but it just stops the splash. So I'm down loading
    Knoppix,Slax,BeatrIX
    This will take a while.
    The distros are larger than I need for this
    all I need is a kernel some way to mount hda1 and an editor

  8. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    eurika

    if you
    push e
    and then
    Code:
     [tab]
    you get a boot prompt
    boot:

  9. #8
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    You don't really want the prompt (grub>). You want to get to the boot script used by Grub. When the splash comes up, press any key (I favor the up-down arrow keys because they don't send a character). That will stop the countdown timer. THEN you press 'e' after selecting the correct "title" on the menu, using the up-down arrow keys. That should show you the three lines used to boot, with initial keywords of: 'root', 'kernel' and 'vmlinuz'. Then, select the line to edit (starts with 'kernel'), press 'e' again, and that's when you add the word "single", at the end of the line. I hope that's clear and helpful.
    /IMHO
    //got nothin'
    ///this use to look better

  10. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    press'e'

    Correct pressing down arrow key stoppes the timer,
    However pressing
    Code:
     'e'
    does nothing....
    If I press tab I get a
    Code:
    Boot:
    If I hit Tab again I get a menu
    but ther is only one option
    YOS
    There are no other options here..

  11. #10
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    dylunio Thanks

    SLAX to the rescue.........
    Worked like a charm............
    :P :P :P :P :P :P
    Thankx a bunch
    would you like to see what got me into this mess?
    Code:
    # start Apache web server
    cd /usr/local/apache2/bin/
    ./apachectl start
    echo "apache up"
    echo "time for mysql"
    cd /usr/bin/
    ./mysql_safe
    #start ssh
    /usr/bin/sshd
    for some reason safe_mysqld just hangs like its in debug mode. How do I make it go into damon mode?
    This why I got locked out.
    and sshd doesn't start becaus of this reason....
    any suggestions?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •