Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    I get an error when i try to run Azureus. Is it my Java?

    Whenever i type "./azureus" or "sh azureus" into a terminal, it gives me this error:

    Starting Azureus...
    Java exec found in PATH. Verifying...
    Suitable java version found [java = 1.4.2_06]
    Configuring environment...
    Loading Azureus:
    java -Xms16m -Xmx128m -cp "/home/kevin/Downloads/Azureus/azureus/Azureus2.jar:/home/kevin/Downloads/Azureus/azureus/swt.jar:/home/kevin/Downloads/Azureus/azureus/swt-mozilla.jar:/home/kevin/Downloads/Azureus/azureus/swt-pi.jar" -Djava.library.path="/home/kevin/Downloads/Azureus/azureus" -Dazureus.install.path="/home/kevin/Downloads/Azureus/azureus" org.gudy.azureus2.ui.swt.Main ''
    Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/kevin/Downloads/Azureus/azureus/ /home/kevin/Downloads/Azureus/azureus/ cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Libra
    at org.eclipse.swt.internal.gtk.OS.<clinit>( 9)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Conve
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Conve
    at org.eclipse.swt.widgets.Display.<clinit>(Display.j ava:11
    at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<ini t>(
    at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.crea teInstance(
    at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<i nit>(
    at org.gudy.azureus2.ui.swt.Main.<init>(
    at org.gudy.azureus2.ui.swt.Main.main(
    Azureus TERMINATED.

    Does anyone know whats wrong? I think it might have something to do with my java version. Thanks.

  2. #2
    The part about
    Java exec found in PATH. Verifying...
    Suitable java version found &#91;java = 1.4.2_06&#93;
    convinces me that there is nothing wrong with the version of Java installed on your system. My guess would be that your version of Azureus is corrupted or out-of-date. What version of Azureus do you have?

  3. #3
    Oh, never mind, i figured it out. It was my azureus version.

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts