Find the answer to your Linux question:
Results 1 to 5 of 5
This is question from a newbie, when it comes to yoper. 1. I have recently tried my hand at installing yoper on machine with Windows NT already present. It also ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Location
    Bangalore
    Posts
    15

    grub not booting kernel in yoper distribution


    This is question from a newbie, when it comes to yoper.
    1. I have recently tried my hand at installing yoper on machine with Windows NT already present. It also had a linux partition. I have used the ISO Cd.
    MY yoper was 1.o version.

    2. I have installed yoper in novesa mode.

    3. I have chosen, the linux partition which was already present on that system as home and other partition, which was swap partition of earlier linux, as swap partition.

    Before installing yoper my system was: (using fdisk -l)

    filesystem
    hda b w95 fat32
    hda2 5 extended
    hda3 85 linux
    hda4 82 linux swap
    hda5 b w95, fat32

    ***********
    I have chosen hda3 as my home for yoper, and hda4 and linux swap.
    This i have chosen with the intention, that it will overwrite the original linux partitions. Because i want to install yoper on top on available linux.

    I got installed, giving me the message to reboot.

    1.
    But The first screen, did not show the Windows OS's existence.

    2.
    It showed "Yoper 1.0" after grub loaded.

    3.
    When i clicked on "Yoper 1.0" to allow it to boot and go to Yoper, the message it gave was:::
    ******************
    Booting 'Yoper 1.0'
    root(hd0, ROOTPART)
    Error 11: Unrecognized device string
    Press any key to continue
    *********************
    4.
    When i edited using "e" to
    root( hd0, 1) , in first line it showed when pressed 'e'

    the message it showed was

    ******************
    Booting 'Yoper 1.0'
    root(hd0, 1)
    File sytem type unknown partition type 0x5
    kernel /boot/vmlinuz-2.6.7-2 root=/dev/ROOT ro
    Error 17: Canont mount selected partition
    Press any key to continue
    *********************
    5.
    Next try was with : root( hd0, 2) ,
    in first line it showed when pressed 'e'

    the message it showed was

    ******************
    Booting 'Yoper 1.0'
    root(hd0, 1)
    File sytem type is ext2fs, partition type 0x83
    kernel /boot/vmlinuz-2.6.7-2 root=/dev/ROOT ro
    Error 15: File not found
    Press any key to continue
    *********************

    *************************************************

    So after those trials and errors, i finally thought to post this question.

    1.
    My goal is to install yoper, with windows present,
    i.e. it should show yoper and windows in grub

    I know that if i able to go inside yoper, i can change the grub.conf file and add windows title with rootnoverify option.

    But it seems i am stuck..

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    have a look at the general tutorial section of this site, for a post on solving boot problems with grub.

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Linux Newbie
    Join Date
    Aug 2005
    Location
    South India, 79 E 11 N
    Posts
    109

    yoper boot problem

    i have installed version which is latest.
    during boot instal it adviced the grub is still experimental with yoper and one is better off with lilo.
    i have no problem with it.

    tv
    Be happy. Life is too short to be unhappy!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Location
    Bangalore
    Posts
    15
    Thanks for the replies.

    when i made a hard toil at what was the actual problem, i got to knew that:

    Grub was showing the wrong version of kernel. This kernel version was not present in my CD.

    It was showing 2.6.7-2 but when i checked that, the real version was : 2.6.8.1-3.
    So i edited the grub entry as per that to:

    kernel /boot/vmlinuz-2.6.8.1-3 root=/dev/hda3 ro

    And phew !!! at last i could see, those messages on screen, "Uncompressing the kernel". So i was through with that.



    But again when i changed the "grub.conf" file in "/boot/grub/" folder, i again got stuck. Because Grub failed to load.
    I agree, my change was major one: I changed the label of "Yoper 1.0" to "linux-2.6.8.1-3".
    My PROBLEM: How to escape grub in such situations. Is there any way to directly go to linux or windows, by escaping grub.
    And is it necessary to have label names sames as the distribution we are using???

  6. #5
    Linux User Game master pro's Avatar
    Join Date
    Sep 2005
    Location
    Tasmania, australia
    Posts
    274
    You could boot into something like knoppix to edit things, you wouldn't be in windows, but you _should_ be able to access both particions, or you could do a windows boot disk, but that would just be dos, although something i'm pretty sure that would get you back into windows is Reinstall windows but instead of going "format drive" go "Replace system files" or something like that so you still keep all you things on the harddrive but it chages all the boot files back to default, so you go into windows without grub or anything.
    oh yeah i know now, make a windows boot disk and in A:/> prompt type "fdisk /mbr" and i'm pretty sure that'll fix it, but don't sue me if it doesn't

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •