Find the answer to your Linux question:
Results 1 to 3 of 3
Small problem. I mainly use XP but like to pop into Ubuntu every now and again, I did so the other night, and a few updates were waiting for me. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Problems with GRUB


    Small problem.

    I mainly use XP but like to pop into Ubuntu every now and again, I did so the other night, and a few updates were waiting for me. I didn't really change anything that would affect the booting, but when I shutdown the next morning, horror of horrors, I noticed that the only options in GRUB were the various Ubuntu options, and not any Windows boots (effectively making it impossible for me to boot to XP). I'm wondering if this has to do with a kernel update, but it's irrelevant, how on earth do I change GRUB to have an option to boot windows again?

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    when you updated your kernel it is quite probable that your distro automatically updated grub (not so nicely in fact) and deleted your windows entry. Just boot into ubuntu. Point your favorite text editor to: /boot/grub/grub.conf (or menu.lst) and add windows entry:

    should look something like this:

    Code:
    Title=Windows XP
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    obviously the (h0,0) part will be determined by where you windows installation is: Grub names things differently so (hd0,0) is actually hda1

    here is a short list
    hda1 (hd0,0)
    hda2 (hd0,1)
    hda3 (hd0,2)
    hdb1 (hd1,0)
    hdb2 (hd1,1)
    hdb3 (hd1,2)
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3
    I figured it would be something like that, I've messed with GRUB before because it auto loads into ubuntu after 10 seconds which is annoying if I want to turn on the computer and leave it to boot, because by default I boot into XP.

    Just had no idea what to actually insert into the conf file, I checked after I had posted (stupid!) and as you can guess, it wasn't there - cheers.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •