Find the answer to your Linux question:
Results 1 to 2 of 2
Wow, I'm the first to post in the Mepis Threads! Ok here's my problem, when I try to configure pango-1.4.0 I get this error: Code: checking for GLIB - version ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    5

    1st Mepis Post:) \ Pango pkg-config issues...


    Wow, I'm the first to post in the Mepis Threads! Ok here's my problem, when I try to configure pango-1.4.0 I get this error:

    Code:
    checking for GLIB - version >= 2.4.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.10.0, but GLIB (2.8.5)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** Glib 2.4.0 or better is required. The latest version of
    *** Glib is always available from ftp://ftp.gtk.org/.
    I've tried to install glib-2.0, 2.4.0, 2.8.5, and 2.10.0 I still get this error ( I guess because of pkg-config which I don't know how to fix?) This is what I have in pkg-config now:

    Code:
    root@1[pango-1.4.0]# pkg-config --list-all
    gmodule-export-2.0    GModule - Dynamic module loader for GLib
    renderproto           RenderProto - Render extension headers
    libpcre               libpcre - PCRE - Perl compatible regular expressions C library
    lcms                  lcms - LCMS Color Management Library
    gmodule-2.0           GModule - Dynamic module loader for GLib
    gnome-mime-data-2.0   gnome-mime-data - Base set of file types and applications for GNOME
    libxine               libxine - The xine engine library
    glib-2.0              GLib - C Utility Library
    gobject-2.0           GObject - GLib Type, Object, Parameter and Signal Library
    gthread-2.0           GThread - Thread support for GLib
    libpng                libpng - Loads and saves PNG files
    zvbi-0.2              ZVBI - VBI Capturing and Decoding Library
    gmodule-no-export-2.0 GModule - Dynamic module loader for GLib
    libpng12              libpng - Loads and saves PNG files
    shared-mime-info      shared-mime-info - Freedesktop common MIME database
    atk                   Atk - Accessibility Toolkit
    root@1[pango-1.4.0]#
    As you can see glib-2.0 is there. What should I do from here?

  2. #2
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Unhappy

    I'm having pretty much the same issue trying to compile Pango under MacOS X 10.4

    Anymore insight from your side?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •