Find the answer to your Linux question:
Results 1 to 3 of 3
There's probably been a lot of posts in regards to this, and here's another one. I've checked out a few of said posts on numerous sites, but they didn't end ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    16

    Hard Drive Permissions


    There's probably been a lot of posts in regards to this, and here's another one. I've checked out a few of said posts on numerous sites, but they didn't end up being very helpful.

    Here's the issue, I recently reformatted drive hdc, putting the files that were on it onto hdb. Now that hdc is formatted and partitioned as I want it to be, I want to move the files back over to hdc2 from hdb2. But it won't let me. I can't create folders or move files onto hdc2 as root, or as a user. I figure it's a drive permission issue..

    I added the 'users' option to its dynamic entry, and apparently umask is a good thing to have, but I don't really know what all those options are. I also read somewhere that in order to have your changes take in fstab, you have to have your drives static, and not dynamic. How do I do that?

    In addition to giving me advice to what I'm supposed to do to fix this, can someone explain/direct me to where I can find out what exactly all the terms mean?

    Here's my current fstab: (I'm running MEPIS 3.3.1)

    # Static entries below, do not use 'users' option in this area
    /dev/hda1 / ext3 defaults,noatime 1 1
    /dev/hda2 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/hda3 /home ext3 defaults,noatime, 1 2
    # Dynamic entries below, identified by 'users' option
    /dev/hdb1 swap swap sw,pri=1 0 0
    /dev/hdb2 /mnt/hdb2 reiserfs noauto,users,exec,noatime,notail 0 0
    /dev/hdc1 /mnt/hdc1 ntfs noauto,users,exec,ro,umask=0222 0 0
    /dev/hdc2 /mnt/hdc2 ntfs noauto,users,exec,ro,umask=0222 0 0

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by Quaenorde
    /dev/hdc1 /mnt/hdc1 ntfs noauto,users,exec,ro,umask=0222 0 0
    /dev/hdc2 /mnt/hdc2 ntfs noauto,users,exec,ro,umask=0222 0 0[/b]
    Ok, first the drive /dev/hdc is mounted read-only (the options "ro" and "umask=0222").

    Second, you simply can't write to a NTFS formated drive in Linux, at least not easily or reliably.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    16
    Quote Originally Posted by antidrugue
    Ok, first the drive /dev/hdc is mounted read-only (the options "ro" and "umask=0222").

    Second, you simply can't write to a NTFS formated drive in Linux, at least not easily or reliably.
    I should have guessed what 'ro' stood for. Anyway, I changed the partition type to fat32, and I was able to move the files freely. Thankies for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •