Find the answer to your Linux question:
Results 1 to 3 of 3
Ive had Xorg installed on another install of LFS before and it went on dead easy. This time its giving me trouble. Im following the latest BLFS and its all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    14

    Linux from Scratch X installation problem


    Ive had Xorg installed on another install of LFS before and it went on dead easy. This time its giving me trouble. Im following the latest BLFS and its all going on LFS 6.1.

    Ive tried to install Xorg about 6 times now and everytime I get to the same part. Im up to the bit where I have to enter
    Code:
    cd ~ &&
    Xorg -configure
    It says
    Xorg:command not found

    I had this problem the last time I installed Xorg only I hadn't
    done the /etc/profile.d/X.sh part in chapter 3.
    I have done that this time and then entered
    Code:
    source /etc/profile.d/X.sh
    It says
    pathappend:command not found
    pathappend:command not found

    does anyone know where I have gone wrong? All the stages before this one went fine, and the LFS install was my 4th one. It went smoother than ever. If I cant get round this problem are there any generic steps for installing X worth trying. Untill now I have only ever followed the books.

    Many Thanks

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    My guess, from what you've described, is that the script /etc/profile.d/X.sh is trying to append one or more directories to the path using the 'pathappend' command, but that command isn't there (or isn't in the current path). Admittedly, I've never heard of pathappend, so that might be a tool that's particular to LFS, or just isn't in wide use, or is deprecated but hasn't been replaced in the script.

    Further, the directory(s) that the script was trying to append probably include the 'Xorg' command. Since that directory didn't make it into the path, you get a 'command not found' error when you try to run Xorg.

    If "pathappend:command not found" is the only error you get from that script, what I recommend is you look in the script to see what directories it's supposed to add to the path, add those directories yourself, and then continue with the step that follows running that script.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    14
    Hi, Thaks for your reply.

    I turned my computer on this morning to try it again and it simply worked.
    Nothing had changed, maybe the reboot helped somehow?

    Either way, its on and ive also ibstalled Xfce since.

    Once again many thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •