Im running the 2.6.14.5 Kernel using Trustix, and I noticed that none
of roots cronjobs (like logrotate) were running. I restarted the fcron
daemon, but didnt seem to fix the problem. To verify this, I used the
fcrondyn program, which allows you do things dynamically with cronjobs.
So I ran fcrondyn in debug mode and here is what I saw:

#fcrondyn -d
08:58:50 fcronconf=/etc/fcron.conf
08:58:50 called with echo='OFF', prompt='password for root :'.
password for root :
fcrondyn>


At this point I ran a listing (ls root)


fcrondyn>ls root
command : ls
uid = 0
ID SCHEDULE CMD
No corresponding job found.


Yet, my roots crontab file reads:


SHELL=/bin/bash
PATH=/sbin:/bin:/usr/bin:/usr/sbin


#run parts
01 * * * * run-parts /etc/cron.hourly
02 0 * * * run-parts /etc/cron.daily
22 0 * * 0 run-parts /etc/cron.weekly
42 0 1 * * run-parts /etc/cron.monthly


On other machines which are running the same software, the results of
the 'ls root' command in the fcrondyn prompt should have produced a
listing of the complete contents of root's crontab, along with job ID's
and other identifying notations.


Ive done a lot of troubleshooting on this issue, including matching up
file permissions, verifying packages, googling a lot and nothing was
come close to working.


Any help whatsoever would be greatly appreciated! I will watch this
thread like a hawk and respond asap to any questions.


Thanks,


Eric