Find the answer to your Linux question:
Results 1 to 3 of 3
I am a newbie, so apologise up front for obvious questions... I have installed DSL onto a USB key. I am trying to install the MadWiFi driver so as to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Installing make in DSL


    I am a newbie, so apologise up front for obvious questions...

    I have installed DSL onto a USB key. I am trying to install the MadWiFi driver so as to get my wireless network running. However, in order to do so, I need to execute the 'make' command - which it seems does not get included with DSL by default.

    So I downloaded the apt package (0.5.28.6) from debian.org and installed it using dpkg. That seems to have worked for apt.
    So then I ran the following from the terminal.
    Code:
    apt-get -y install make
    Then I get the error about unmet dependencies.
    Code:
    apt : Depends: libgcc1 (>=1:3.4.1-3) but 1:3.3.2-0pre4 is installed
    plus another similar error about libstdc++5.

    What am I doing wrong?

  2. #2
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi djgk,
    apt : Depends: libgcc1 (>=1:3.4.1-3) but 1:3.3.2-0pre4 is installed
    You need to install gcc 3.4.1-3 (which was released in October 17th of 2003) or a more recent version of it along with other related libraries. Read the following website on how to download and install gcc : -

    http://www.faqs.org/docs/ldev/0130091154_71.htm

    With Regards,
    Thinker

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2
    Thanks for the pointer.

    After further poking about, I started up synaptic, which then proceeded to install/update a number of things (which scrolled off the screen before I could note them down). That seems to have updated something which has allowed me to proceed.

    I believe I am at the base of a rather steep learning curve!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •