Find the answer to your Linux question:
Results 1 to 4 of 4
I'm having some trouble building a Linux from Scratch system using their own Live CD as a base OS. I am using the Live CD version x84-6.2-2. I have followed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    Linux From Scratch - Chapter 5 - Binutils


    I'm having some trouble building a Linux from Scratch system using their own Live CD as a base OS.
    I am using the Live CD version x84-6.2-2.

    I have followed the book up to the beginning of Chapter 5 before getting stuck.

    I have copied all the packages to my hard drive form the live CD using: cp -R /lfs-sources $LFS/sources

    When trying to complie Binutils my problems arose. When entering: mkdir -v ../bintuils-build

    I received a message saying that I can't do that because permission is denied. I then manually created $LFS/sources/binutils-build

    When I entered ../lfs-sources/binutils-2.16.1/configure --prefix=/tools --disable-nls the promt returned that there was 'No such file or directory'

    I am probably doing something really stupid but any help would be greatly appreciated.


    Thanks,

    Tom

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Location
    South England
    Posts
    5
    You may need to be 'root' in order to make that directory .
    Enter 'whoami' into a terminal , if you aint root , 'su root' + try again .
    You could also try changing the ownership of the directory to lfs(If thats the user you created to build your lfs system) .

    In bash , you can use the 'tab' key to autocomplete . When you enter
    ../lfs-sources/binutils-2.16.1/configure --prefix=/tools --disable-nls
    press tab when you're at '..../binutils-2' and see if it autocompletes .
    if it doesnt , then they aint lying when they say;
    'No such file or directory'

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    read 5.3.1 again in the LFS 6.1.

    Some how I think we needed to find our path as $LFS/tools/source. Then when we run the mkdir ../binutils-build it makes the directory $LFS/tools/binutils-build... Where they left us off, is a directory on the CD... not even root has permision to create a file on the CD, and that is the error.

    I believe I just figured it out. I hope it works. I'll feel foolish if this isn't helpful. let me know if you find a better solution.

  4. #4
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    It's worth it when something goes wrong to do

    echo $LFS to see if it's set and it's set to what it should be. Also don't forget that you have to chown that directory to your lfs user and then login as that user. Be very careful with those permissions, if you do everything as root there will be complications later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •