Find the answer to your Linux question:
Results 1 to 5 of 5
Issue: I cannot set a root password. It is sooo agrravating. When I boot up, I go into the CLI and type sudo su, giving me root access. I then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    34

    DSL customization and other issues


    Issue: I cannot set a root password. It is sooo agrravating. When I boot up, I go into the CLI and type sudo su, giving me root access. I then type 'passwd root'.

    It then prompts me to set a new root password.

    I cannot type anything ARGHH. It's not letting me do anything but hit enter. I can type fine before that command, but as soon as I try and enter a root password, I cannot type anything except hitting enter.

    What solution is there for this?

    Customization: DSL comes with a lot of great stuff, but here's what I'd like to do.

    I'd like to have it all CLI. No gui. I'm not sure how to do this on DSL.

    Also. I'd like to get rid of all the apps except a few. All I want left is firefox, a text editor, and i'll install some form of LAMP and perl.

    I don't have time to manually remove all these things that I don't want, so is there an easier way to do this?

    Thanks for checking the problem out.

    Peace.

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    34
    Alright.... it's not just the DSL root password setting that is a problem.

    I can't set any passwords for anything in the CLI.

    AGHHHH.

    I've installed webmin and i'm trying to set it up.

    It asks me to give a log on name. I leave it at default. Admin.

    It now asks me for a password for webmin.

    Suddenly my keyboard is frozen again! except for the enter key. I can't type any passwords in on anything! Aghhh.

    Any solutions to this?

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Location
    Styx of Carolina
    Posts
    51
    From the sounds of things u are trying to make a DSL Webserver. As for the Password problem i have No Clue... But a solution to your Webserver issue Perhaps try something like WOS (Webserver on a Stick) Combined with 1 Bone Puppy. I have never tried 1 bone puppy linux myself, its basicaly Puppy Linux with nothing but a Command line, a text editor, and a web browser. Or even if WOS is not the right thing for u, 1 bone puppy sounds like an easier solution than manualy stripping DSL. the entire OS would be 28MB + your Apache Server.
    http://www.puppylinux.org/user/downloads.php?cat_id=1
    4th Distro down is 1 bone puppy

    Hope this helps.

  4. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    13
    when you type a psswd in the CLI it doesn't show, but it is still being typed. Just type the word even though you cant see it being typed, and hit enter.

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Location
    Styx of Carolina
    Posts
    51
    MRabbit is correct, i hadn't thought of that as i figured you knew, so congrats, both problems solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •