Find the answer to your Linux question:
Results 1 to 5 of 5
Okay so I have an old Windows XP laptop on which i have recently resized the NTFS partition and reformatted the rest with a new swap partition and a large ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6

    DSL and Partition Table Issues


    Okay so I have an old Windows XP laptop on which i have recently resized the NTFS partition and reformatted the rest with a new swap partition and a large ext2 partition. The laptop only has 128MB of RAM so I intend to run DSL on it so I have a fast OS. I have downloaded DSL 3.10 and images the iso onto a standard 700MB CD. When I go to boot the DSL LiveCD it does all the hardware recognition and configuration then gets to 'creating /etc/fstab...'. It just stops there! No disk activity but it doesn't hang. I have tried multiple times even leaving it for 12 hours to find nothing had changed. I also tried with nofstab but of the boot just stops later when it tries to create the authority files for X.

    Now I'm no expert with linux in particular anything outside normal boot stuff. But I boot up in runlevel 2 with nofstab and dsl successfully boots. The first thing I do is launch fdisk and check the partition table but there isn't one. fdisk can detect the drive but reports there is no valid partition table. So I go and 'cat etc/fstab' but none or the harddrive partitions are there. Now incase you are wondering I partitioned with the System Rescue CD using fdisk on it. So I boot down, reboot with the System Rescue disk inserted go into fdisk and it successfully shows the correct partition table. I resaved the partition table and rebooted into the DSL liveCD but the fdisk on DSL still reports the partition table as invalid.

    I'm guessing the invalid partition table is the cause for the stop of the creation of the fstab file. So what is up with my partition table and how can I resolve this issue?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    try testdisk and verify/fix Partition Table.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    Okay well it appears as though that has fixed the NTFS partition on the partition table because the windows partition is now booting. However, DSL still stops booting when it goes 'creating /etc/fstab'. Also If I run it in runlevel 2 with nofstab fdisk or anything else still won't recognise the partition table. I think I'll try Puppy Linux maybe there is some sort of incompatability with DSL and my hardware configuration.

    EDIT: Hmmm Puppy won't boot either it freezes on starting X while dsl still freezes when its creating fstab. can anyone help?

    EDIT: Puppy linux recognises the partition table. Wierd...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    71

    I have the same issue somewhat!

    cfdisk can't/won't see my disk so i cant install dsl to my hdd which i need to do!

  6. #5
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Arizona
    Posts
    139

    This may not help you...

    This may not help you, but I have to admit that I fell for this.

    I had the exact same error with DSL and DSL-N with regard to the partition table. I then went to Knoppix 5 and Knoppix 5.1 and found that I had the same problem. At first, I thought that it was the disc, then I thought that it was the latest flavors of both distributions.

    Then I found out that I was typing simply 'cfdisk' and 'cfdisk hda'. I invariably received the error stating that the partition table couldn't be read. Admittedly, it took me a while to figure out what it was that I forgot to do.

    'cfdisk /dev/hda' finally worked, and I was able to install DSL onto my new partition. One thing I recommend though, is to try Knoppix or another more robust live distro and run qparted or one of its siblings. It is more feature filled and has a GUI that is familiar.

    I have never encountered the fstab hang on boot, but I most certainly get hung on boot without 'nodhcp' for both DSL and Knoppix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •