First of all I’d like to apologize You for my poor english.
I realy like DSL distribution, when I saw it I immediately decided to install on hard drive. Since then my three days horror start (maybe because I’m a Newie). I’ve tried every possible configurations,unfortunately without any results.

During the installation I use a guide:
http://distro.ibiblio.org/pub/linux/...rugalHowto.pdf
Except i use dsl-hdinstall for installing ,not frugal_instal.sh
The partitions look like that:

/dev/hdc1 dla /
/dev/hdc5 dla swap
/dev/hdc6 dla /home

I’ve tried to (participate) on cfdisk as follows:
hdc1, hdc6 – Linux (83)
hdc5 swap (82)
when its not worked i tried
hdc1, hdc5, hdc6 – Linux (85)
and some other combinations
and then commands mke2fs, mkswap, swapon
I’ve also tried without these commands.

It looks like installation goes fine, problems appear during installaion of bootloader.
I get errors (information) as follows:

LILO
Code:
/usr/sbin/dsl-installboot: line 181:745 segmentation fault
/usr/sbin/genliloconf „$TARGET” „$TARGET” „hda=scsi apm=power-off nomce noapic” „$BKERNEL” $INITRD
Warning: ‘/proc/partitions’ does not exist, disk scan bypassed
Modprobe: modprobe: C’ant locate module block-major-3

EXT2-fs warning (device ide1(22,1)):
Ext2_read_super: mounting ext3 filesystem as ext2
GRUB
Code:
Modprobe: modprobe: cant locate module block-major-3
When booting system:
GRUB HARD DISK ERROR

I have no idea what to do, and I want very much to install that system.
Please, help me.