Find the answer to your Linux question:
Results 1 to 5 of 5
I am trying to set up my fstab so that certain partitions will be mounted automatically at boot and be writeable by all users. I understand how this works, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Help fstab mount shared partitions at boot


    I am trying to set up my fstab so that certain partitions will be mounted automatically at boot and be writeable by all users. I understand how this works, and I have managed to modify the fstab to do this for a shared windows (fat32) partiition, but can not seem to make it work for a an ext3 partition. As root I can still mount it manually, but it seems that no matter what I do, the user can not access it or mount it. My current fstab is below:

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/hdb1 / ext3 defaults,noatime 1 1
    /dev/hdb3 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/hda3 /mnt/hda3 vfat auto,users,exec,rw,umask=000 0 0
    /dev/hdb2 /home ext3 defaults,noatime 1 2
    /dev/hdd1 /mnt/hdd1 ext3 auto,users,exec,rw,umask=000 0 0
    # Dynamic entries below, identified by 'users' option
    /dev/hda1 /mnt/hda1 ntfs-3g noauto,users 0 0
    /dev/hda2 /mnt/hda2 auto noauto,users,exec 0 0
    /dev/cdrom /media/cdrom iso9660,udf noauto,users,exec,ro 0 0

    Permissions on the mount point are set to allow all users access (as user I can copy files into it) but still I can not seem to get the partition to mount at boot for all users to access. /hdd1 is the partition I am attempting to mount and share with all users. Any help is appreciated.

    If it makes a difference I am using Mepis.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !

    remove "umask=0000" from /dev/hdd1 line.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2
    Thank you very much, that fixed it!


  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    glad to help you.
    umask is for setting mask permissions for NTFS and FAT32 partitions only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    7
    Oh its really worked thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •