Find the answer to your Linux question:
Results 1 to 8 of 8
Will you take a look at my /etc/fstab to help me figure out why my DVD-RW drive does not mount? # Pluggable devices are handled by uDev, they are not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2005
    Location
    CA
    Posts
    104

    FSTAB Problem


    Will you take a look at my /etc/fstab to help me figure out why my DVD-RW drive does not mount?

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/sda2 / ext3 defaults,noatime 1 1
    /dev/sda1 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/sda3 /home ext3 defaults,noatime 1 2
    # Dynamic entries below
    /dev/hda1 /mnt/hda1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/sdb1 /mnt/sdb1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/cdrom /media/cdrom iso9660,udf noauto,users,exec,ro 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0

    Thanks in advance!
    Linux is numero uno! I have taken up Archery.
    ______________________

  2. #2
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    556
    Quote Originally Posted by rj586b View Post
    Will you take a look at my /etc/fstab to help me figure out why my DVD-RW drive does not mount?

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/sda2 / ext3 defaults,noatime 1 1
    /dev/sda1 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/sda3 /home ext3 defaults,noatime 1 2
    # Dynamic entries below
    /dev/hda1 /mnt/hda1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/sdb1 /mnt/sdb1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/cdrom /media/cdrom iso9660,udf noauto,users,exec,ro 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0

    Thanks in advance!
    According to your fstab you have one CD/DVD device. If that's the only one, theoretically it should be working. I had many problems with MEPIS's CD/DVD/USB handling. I could not predict when will it work, and when not. Try the manualy working with> mount /dev/cdrom

    In other case you should add manually an entry for cdrom1, but i'm not shure!
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  3. #3
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    468
    You don't mount a cdrom or dvd drive. You insert a disk and it should auto-mount.
    Glenn
    Powered by Fedora

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jun 2005
    Location
    CA
    Posts
    104
    There is a disk already inside from before this happened.

    When I try to manually mount it in a terminal I get this message:
    [mount: Too many levels of symbolic links]

    Strange - My /etc/fstab now comes up with 2 entries after I deleted one already. Maybe if I delete both, it will work.

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/sda2 / ext3 defaults,noatime 1 1
    /dev/sda1 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/sda3 /home ext3 defaults,noatime 1 2
    # Dynamic entries below
    /dev/hda1 /mnt/hda1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/sdb1 /mnt/sdb1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
    /dev/ /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0

    Thanks
    Linux is numero uno! I have taken up Archery.
    ______________________

  6. #5
    Linux Newbie
    Join Date
    Jun 2005
    Location
    CA
    Posts
    104
    Well, unfortunately my plan didn't work. I was able to get the cd out during boot up. The drive now opens by pushing the buttong but won't mount after inserting another cd.

    Let me know if you have any ideas.

    This is what I have in fstab now:
    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/sda2 / ext3 defaults,noatime 1 1
    /dev/sda1 swap swap sw,pri=1 0 0
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    /dev/sda3 /home ext3 defaults,noatime 1 2
    # Dynamic entries below
    /dev/hda1 /mnt/hda1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/sdb1 /mnt/sdb1 vfat,ext3,ext2,reiserfs noauto,users,exec 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0
    /dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
    Last edited by rj586b; 05-29-2007 at 12:18 AM. Reason: More info was needed on the 1st line.
    Linux is numero uno! I have taken up Archery.
    ______________________

  7. #6
    Linux Newbie
    Join Date
    Jun 2005
    Location
    CA
    Posts
    104
    O.K. Every time I restart, I end up with 2 cdrom fstab entries.
    Linux is numero uno! I have taken up Archery.
    ______________________

  8. #7
    Linux Enthusiast minthaka's Avatar
    Join Date
    May 2006
    Location
    Mol, Vojvodina
    Posts
    556

    Smile

    I don't know whether thishelps you or not, but the dynamic entries in your fstab are being rewritten each time you boot up your system. I never could manage your problem, never ever succeeded to eject CD/DVD pushing the button on the devices. I could only make them open with right-click + Eject. Sometimes the CD/DVD won't mount, I never knew why, so I've tried to mount them manually, and sometimes it worked. There were periods of time when all worked O.K then again encountered the same troubles. This was one of the main reasons I've left Mepis. Something is buggy in it!

    Maybe you should try to place CD/DVD devices among the static entries with noauto mounting option, and put an icon of them on your desktop.
    If you need a CD/DVD catalogizer, give a try to my program:
    http://www.kde-apps.org/content/show...content=100682
    Linux Usert#430188

  9. #8
    Linux Newbie
    Join Date
    Jun 2005
    Location
    CA
    Posts
    104
    Of course the information helps. I appreciate all of your help

    This is really weird - I get home from work and my wife has windows up so I reboot. When Mepis comes up I put in a CD and it mounts. fstab has these two entries for cdrom but hey, it works.

    /dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
    /dev/hdb /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0

    My system also used to hang on boot up configuring network interfaces and it stopped doing that as well. Both problems were mysteriously fixed.

    Those Gremlins!

    Anyway, thanks again for your help!
    Linux is numero uno! I have taken up Archery.
    ______________________

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •