Find the answer to your Linux question:
Results 1 to 7 of 7
Just installed latest SimplyMepis. When I tried to copy my Firefox Bookmarks, CD-ROM didn't show up anywhere??? Any help greatly appreciated. Where does it normally mount and what is the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243

    Mepis does not recognize CD-ROM


    Just installed latest SimplyMepis. When I tried to copy my Firefox Bookmarks, CD-ROM didn't show up anywhere??? Any help greatly appreciated. Where does it normally mount and what is the device (/dev/???). I check media; there is a cdrom and a cdrom1, but there are both empty. There is nothing in /mnt.

  2. #2
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    Quote Originally Posted by Pumalite View Post
    Just installed latest SimplyMepis. When I tried to copy my Firefox Bookmarks, CD-ROM didn't show up anywhere??? Any help greatly appreciated. Where does it normally mount and what is the device (/dev/???). I check media; there is a cdrom and a cdrom1, but there are both empty. There is nothing in /mnt.
    This is what I got so far:

    Called: mount /dev/cdrom
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so ( from KwiDisk)

    And this is the output of dmesg | tail:

    pumalite@1[~]$ dmesg | tail
    [17236803.824000] attempt to access beyond end of device
    [17236803.824000] hdc: rw=0, want=68, limit=4
    [17236803.824000] isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16
    [17236803.852000] attempt to access beyond end of device
    [17236803.852000] hdc: rw=0, want=68, limit=4
    [17236803.860000] attempt to access beyond end of device
    [17236803.860000] hdc: rw=0, want=1252, limit=4
    [17236803.860000] attempt to access beyond end of device
    [17236803.860000] hdc: rw=0, want=1028, limit=4
    [17236803.860000] UDF-fs: No partition found (1)
    pumalite@1[~]$


    The funny thing is that k3b does recognize CD-ROM. Any ideas? What am I doing wrong? or What am I reading wrong? Total newbie, especially to Mepis. I have Suse 10.2 in another drive and Ubuntu 6.10 in another partition ( in the same drive as Mepis) in the same machine. The other two distros have no problems with CD-ROM ( it mounts itself every time I put a disk inside ). Thanks for any help.

  3. #3
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    Quote Originally Posted by Pumalite View Post
    This is what I got so far:

    Called: mount /dev/cdrom
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so ( from KwiDisk)

    And this is the output of dmesg | tail:

    pumalite@1[~]$ dmesg | tail
    [17236803.824000] attempt to access beyond end of device
    [17236803.824000] hdc: rw=0, want=68, limit=4
    [17236803.824000] isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16
    [17236803.852000] attempt to access beyond end of device
    [17236803.852000] hdc: rw=0, want=68, limit=4
    [17236803.860000] attempt to access beyond end of device
    [17236803.860000] hdc: rw=0, want=1252, limit=4
    [17236803.860000] attempt to access beyond end of device
    [17236803.860000] hdc: rw=0, want=1028, limit=4
    [17236803.860000] UDF-fs: No partition found (1)
    pumalite@1[~]$


    The funny thing is that k3b does recognize CD-ROM. Any ideas? What am I doing wrong? or What am I reading wrong? Total newbie, especially to Mepis. I have Suse 10.2 in another drive and Ubuntu 6.10 in another partition ( in the same drive as Mepis) in the same machine. The other two distros have no problems with CD-ROM ( it mounts itself every time I put a disk inside ). Thanks for any help.
    This is my /etc/fstab:

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/hda1 / ext3 defaults,noatime 1 1
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    # Dynamic entries below, identified by 'users' option
    /dev/hda2 /mnt/hda2 ext3 noauto,users,exec 0 0
    /dev/hda3 /mnt/hda3 auto noauto,users,exec 0 0
    /dev/hda4 /mnt/hda4 ext3 noauto,users,exec 0 0
    /dev/hdb1 swap swap sw,pri=1 0 0
    /dev/hdb2 /mnt/hdb2 ext3 noauto,users,exec 0 0
    /dev/hdb3 /mnt/hdb3 ext3 noauto,users,exec 0 0
    /dev/hdd1 /mnt/hdd1 ext3 noauto,users,exec 0 0
    /dev/cdrom /media/cdrom iso9660,udf noauto,users,exec,ro 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0
    /etc/fstab (END)

    The line for cdrom is in my fstab, but when you go to look in 'roo' and check 'media', cdrom is empty. I have the Icon in my Desktop. When I right click on it, it gives me the option to mount, so I doit; nothing happens ( no errors) and when i right click again the option to mount has disappeared, so I assumed is mounted; I go to the option to 'Open' and then I get confronted with the same error as in KwiDisk: ( this time from KDesktop ):

    Could not mount device.
    The reported error was:
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    Please help.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    Quote Originally Posted by Pumalite View Post
    This is my /etc/fstab:

    # Pluggable devices are handled by uDev, they are not in fstab
    /dev/hda1 / ext3 defaults,noatime 1 1
    none /proc proc defaults 0 0
    none /proc/bus/usb usbfs devmode=0666 0 0
    none /dev/pts devpts mode=0622 0 0
    none /sys sysfs defaults 0 0
    # Dynamic entries below, identified by 'users' option
    /dev/hda2 /mnt/hda2 ext3 noauto,users,exec 0 0
    /dev/hda3 /mnt/hda3 auto noauto,users,exec 0 0
    /dev/hda4 /mnt/hda4 ext3 noauto,users,exec 0 0
    /dev/hdb1 swap swap sw,pri=1 0 0
    /dev/hdb2 /mnt/hdb2 ext3 noauto,users,exec 0 0
    /dev/hdb3 /mnt/hdb3 ext3 noauto,users,exec 0 0
    /dev/hdd1 /mnt/hdd1 ext3 noauto,users,exec 0 0
    /dev/cdrom /media/cdrom iso9660,udf noauto,users,exec,ro 0 0
    /dev/fd0 /media/floppy vfat,ext2 noauto,users,exec,rw 0 0
    /etc/fstab (END)

    The line for cdrom is in my fstab, but when you go to look in 'roo' and check 'media', cdrom is empty. I have the Icon in my Desktop. When I right click on it, it gives me the option to mount, so I doit; nothing happens ( no errors) and when i right click again the option to mount has disappeared, so I assumed is mounted; I go to the option to 'Open' and then I get confronted with the same error as in KwiDisk: ( this time from KDesktop ):

    Could not mount device.
    The reported error was:
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    Please help.
    The problem is only with CD-RW. With CD-R's, the device mounts itself and reads it as long as it recognizes it. This problem is partially solved.

  6. #5
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    Quote Originally Posted by Pumalite View Post
    The problem is only with CD-RW. With CD-R's, the device mounts itself and reads it as long as it recognizes it. This problem is partially solved.
    I rebooted with the CD-RW on the drive and now is recognized. So, the problem is solved; I guess.

  7. #6
    Just Joined!
    Join Date
    Jul 2007
    Posts
    13

    Likewise ..

    I get that sometimes also...
    requiring a reboot for some reason or another....

    After rebooting it's magically there....now this didn't do this
    prior to 6.5 with any of the same exact hardware.....

    guess we will just have to watch it and work out the kinks ...

    ciao

    burdicda

    * Just letting you know your are not imagining things there are others out here
    with the same problem...

  8. #7
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    I had the same problem in Ubuntu 7.04. I solved it by going to BIOS>IDE Configuration>Advanced Support>Support PATA+SATA. Hope it helps someone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •