Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi all, i'm new on this forum and i hope you will help me I'va got two boxes: an old box where my LFS system works and a new one ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12

    Unhappy Getting all boot messages in a file


    Hi all,

    i'm new on this forum and i hope you will help me

    I'va got two boxes: an old box where my LFS system works and a new one where i can't get it boot. My problem is the following. When my system is booting on the new box, it prints a lot of message on my screen and i can't read them since it prints faster than i can read!

    Messages look like : [<c0...>] function_name ...

    but i can't read more than that and i can't find what is my problem just with that. So my question is: can i redirect all boot messages in a file ?

    I'm using grub, here is my /etc/syslog.conf:
    auth,authpriv.* -/var/log/auth.log
    *.*;auth,authpriv.none -/var/log/sys.log
    daemon.* -/var/log/daemon.log
    kern.* -/var/log/kern.log
    mail.* -/var/log/mail.log
    user.* -/var/log/user.log
    *.emerg *
    but i don't have those message in the log file...
    Do you have THE solution to my problem ?

    Thanks a lot for your help!
    pico.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    did you check 'dmesg' ?
    Code:
    dmesg | less
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12
    it seems that i have forgotten to say that system doesn't boot on the new machine. It begin to boot and keyboard works well to configure bios but when i have those messages, i can't use keyboard. I just can shutdown the box by the power button...

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    toggle 'Legacy USB support' in BIOS. keyboard will work after that.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12
    i have check in the kernel and usb keyboard is enable.

    i have seen something like "do_page_fault" in the error message, perhaps a "disable" and a "clear" but i can't see more than that.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    could you post last visible error messages?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12
    no, i can't since i can't really read messages. I just have guess the mesage "do_page_fault".

    I have recompiled my kernel without smp support and i have a kernel panic. There is an interrupt problem about apic. I don't know what is apic, i will search on google.

    With smp support, it seems that it make a loop. There are always the same error messages.

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    apic
    pass noapic parameter to kernel. ( append kernel line with noapic in grub.conf ).
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12
    it doesn't work

  10. #10
    Just Joined!
    Join Date
    Jun 2007
    Posts
    12
    here are some additional informations!

    when i disable SMP (i don't need it) it doesn't boot and it finish on smp_apic_timer_interrupt

    so i decided to disable APIC mode in my kernel configuration but i can't

    i do make menuconfig and don't see options so i have edited the .config file and commented all lines with APIC but when typing make, it enable again the APIC options

    do you have any solution ?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •