Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Linux LiveCD Router

    I had an old AMD K6-2 500 lying around and a need for a router so I decided to pick up Linux LiveCD Router. I personally don't have a ton of experience setting up a hardware firewall, but I read through a lot of the documentation and know most of what's going on.
    The problem I'm running into is eth0 will grab the default 192.168.x.x address and doesn't seem to allow DHCP to configure it at all. Is there a command to renew the ip of eth0 (like the DOS command ipconfig/renew)?
    Ifconfig fully recognizes the cards, I just can't get it to grab the IP it needs.

  2. #2


    Comcast is my service provider and I don't know if the have anything to do with it, but is there any information I need to specify when I set up the DHCP hostname or anything specifically for them? I don't have any problems on Ubuntu or Windows. Just a thought.

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    192.168.x.x sounds like a LAN address, or at least it is one of the most common associated with routers. Are you certain this is not correct? 169.x.x.x would be the default address when DHCP fails.

  4. $spacer_open
  5. #4
    The IP it grabs is which is the address it should grab right before it gets the address through DHCP client. The address it SHOULD get through comcast is something along the lines of 68.83.x.x. I've tried pinging google and I've tried opening up lynx but they never receive an outside connection. I also have it set to allow DHCP so I really don't know what's wrong.

  6. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    I believe you can temporary force an Ip with the command line.
    ifconfig eth0 (IP address)
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #6
    Quote Originally Posted by MikeTbob View Post
    I believe you can temporary force an Ip with the command line.
    ifconfig eth0 (IP address)
    I'll give that a try, but I was under the impression that it should automatically grab the proper IP under lease from the DHCP server.

  8. #7
    I tried forcing the IP to no avail. I tried pinging the DHCP server and that timed out also so it's almost like the box doesn't see it. My windows box will automatically see it and obtain an IP lease but my router will not do the same. The problem may be distro specific having something to do with a bad build, (I'm going to try out a different distro) but more likely it may be a more general linux problem with something not being set up correctly. If anyone else has had problems obtaining an IP lease from a DHCP server let me know what you did to fix it.

  9. #8
    As an update, I tried Coyote linux and a FreeBSD floppy-based distro. Neither would autoconfigure to the DHCP address that was given to them much in the same way the Linux Router CD also wouldn't. My Windows and Ubuntu boxes grab their IP just fine (as long as only one is hooked up of course) There has to be something I need to do that I'm not when connecting that Ubuntu and Windows does automagically. If anyone has experience setting up any of the above distros over a Comcast Cable connection let me know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts