Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I just installed PCLOS and am looking to update everything, and get full functionality out of the OS, like play DVDs and WMA files... etc. I've added ALL repositories ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    39

    PCLinuxOS repository issues


    Hello,

    I just installed PCLOS and am looking to update everything, and get full functionality out of the OS, like play DVDs and WMA files... etc. I've added ALL repositories in Synaptic, yet whenever I try to install something (like VLC or libdvdcss, or try to upgrade some things, like Amarok) I get a message that says, error: some dependency is not going to be installed. What do I need to do to make these available? I run Ubuntu normally and opening repositories and getting full functionality was pretty easy, and everything else about PCLOS has been EASIER than Ubuntu, so I must be doing something wrong. Please help if you can.

    Thanks.

    EDIT: Everything (so far) seems to install just fine from the terminal, but this machine is for a SUPER newbie and I'd like to make Synaptic as functional as possible.

  2. #2
    Just Joined!
    Join Date
    Mar 2008
    Posts
    39
    Well the problem seems to have grown and changed...

    I was able to update and upgrade my packages via the terminal, but after reboot I get dumped into command-line. If I boot to Safe-Settings I get an error screen that reads "There are multiple versions of "hal-info" in your system...

    How do I repair this? Thanks.

  3. #3
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Do you get to the login prompt in the terminal? If so, login as root and enter
    Code:
    rpm -qa | grep -i hal
    A list of hal related packages will be listed. Uninstall the older hal-info package using
    Code:
    rpm -e hal-info<$VERSION>
    Replace <$VERSION> with the actual version and then reboot.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2008
    Posts
    39
    I'll definitely give that a whirl.

    Would this issue cause my Xorg problems? I tried XFdrake to reconfigure X to see if that could get me back to the desktop, but after reassigning my Graphics driver (Intel 840 and higher... is the new driver name after the upgrade), I try to test it and I get errors.

    -Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so
    -Failed to load module "intel" (loader failed, 7)

    I tried the Vesa driver, just to get me back to X but that wouldn't load either, and gave these errors:
    -module ABI minor version (2) is newer than server's version
    -Failed to load module "vesa" (module requirement mismatch, 0)

    thanks again.

  6. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    If you are having so many issues after the upgrade, then something could be wrong somewhere. Try upgrading again and see if that helps. The commands to run are
    Code:
    apt-get update 
    apt-get upgrade

  7. #6
    Just Joined!
    Join Date
    Mar 2008
    Posts
    39
    Daark, those are the commands I did run that caused my issue. I think I had too many repositories open, and had a few too many errors because of it. But your code to remove the multiple hal-info package was really what saved me. I was able to salvage my install and upgrade the distro (thanks to the apt-get dist-upgrade command someone at the PCLOS forums passed along).

    So thanks.

    Now, something that has been bothering me; when booting, the splash screen sits for 20-30 solid seconds before the progress bar starts to move. Why is this? I've started without the splash, but don't remember the output. I'll post what I can catch tonight. But any input is definitely welcome.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •