Find the answer to your Linux question:
Results 1 to 9 of 9
Am running PCLinuxOS 2009 with Googleearth from the repos on a Core Duo with 1 Gb of RAM and and nVidia GE6200 card with 256 Mb of RAM as well. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67

    Googleearth crashing


    Am running PCLinuxOS 2009 with Googleearth from the repos on a Core Duo with 1 Gb of RAM and and nVidia GE6200 card with 256 Mb of RAM as well. Am using the nVida 180 driver with Compiz enabled.

    Upon trying to run Ge it crashes my Desktop and i have to perform a hard reboot. home/frazelle09/.googleearth is my folder's local location and one of its folders is Crash but i never get any crash reports so i can't even report this. My xOrg.log does not report any errors. i've Googled all i can but none of the fixes seem to work.

    Is there any way of tracing what is happening or of performing some sort of step-by-step analysis to determine what is going wrong?

    Thanks in advance for any help proffered and have a great evening!

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    try starting GE from the command line, usually this will output an error that will point you in the right direction.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Darn, Mike, you're fast!! i've already tried that and i do see some stuff but the term doesn't last long enough to be able to see much before the whole thing freezes up.

    Thanks for posting and have a great evening!

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Ok try this then.
    Open a terminal window and login as root or use sudo if need be, issue this command.
    Code:
    glxinfo |grep render
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #5
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Mike, thanks a lot! Just got back from Ensenada. i tried your command and got

    Code:
    [frazelle09@LaGrandota ~]$ glxinfo |grep render
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    OpenGL renderer string: GeForce 6200/AGP/SSE2
    My glxgears is now giving double what i was usually seeing, which is rather interesting.

    Code:
    [frazelle09@LaGrandota ~]$ glxgears
    12597 frames in 5.0 seconds = 2514.281 FPS
    12600 frames in 5.0 seconds = 2519.074 FPS
    Have a great evening and thanks for replying!

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I'm confused here, I was under the impression that glxgears would not work if direct rendering is not enabled. Do you have the Nvidia-settings managers installed? It would be somewhere in your system menu. Try using that to enable direct rendering. Does Compiz work correctly?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #7
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Mike, i was under the same impression, but that's what glxgears reports and Compiz works just beautifully!

    i tried running the nVidia setting manager and got a pop-up which said

    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

    i ran nvidia-xconfig as root and it said it wrote a new xorg.config file and i logged out and in again, but when i run glxinfo |grep render again, i get the same output.

    i finally figured out how to run GE without it crashing my system. i run it from a term, then as soon as the window comes up, i minimize it. This way i can see the output in the term and copy it to an editor. The following is what i got.

    Code:
    [frazelle09@LaGrandota ~]$ googleearth
    Locking assertion failure.  Backtrace:
    #0 /usr/lib/libxcb-xlib.so.0 [0xb66ff8b7]
    #1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x32) [0xb66ff992]
    #2 /usr/lib/libX11.so.6 [0xb6a71223]
    #3 ./libGL.so.1(__glXInitialize+0x5d5) [0xb668ce75]
    #4 ./libGL.so.1 [0xb668907d]
    #5 ./libGL.so.1(glXChooseVisual+0x3a) [0xb668ac3a]
    #6 ./librender.so [0xb67cdb9a]
    #7 ./librender.so(_ZN12RenderWidget4initEv+0x11f) [0xb67ceb8f]
    #8 ./librender.so(_ZN12RenderWidgetC1EP7QWidgetPKc6QFlagsIN2Qt10WindowTypeEE+0x172) [0xb67cf472]
    #9 ./librender.so(_ZN5earth6render12RenderWindow12createWidgetEv+0x82) [0xb67d8e62]
    #10 ./libgoogleearth_lib.so(_ZN5earth6client12ModuleWidget9showEventEP10QShowEvent+0x90) [0xb73502d0]
    #11 ./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0xa86) [0xb77ec0d2]
    #12 ./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x1d3) [0xb77b044b]
    #13 ./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x132) [0xb77b703e]
    #14 ./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x62) [0xb7daaeda]
    #15 ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0xf9) [0xb77ee7a9]
    #16 ./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x83) [0xb77ee507]
    #17 ./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x15c) [0xb77ee6a4]
    #18 ./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x60) [0xb77ee710]
    #19 ./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x3bb) [0xb77f0d6b]
    Then, i can close the terminal and my desktop remains just fine! Yea!!

    Another question: If i wish to apply this> direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

    where should it be typed?

    i also checked under Compiz and i have two options: native driver or xgl. i have xgl selected.

    Have a great evening and thanks for posting!

  9. #8
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #9
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Thanks for replying, Mike! i tried the suggestion that your link referred to but GE still crashes and outputs the same info.

    Have a great morning!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •