Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I have a computer that's currently running the RC of Windows 7 that I'm trying to switch over to Linux (because the RC is expired and shuts down every 2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59

    [SOLVED] Linux can't figure out that I have a hard drive


    I have a computer that's currently running the RC of Windows 7 that I'm trying to switch over to Linux (because the RC is expired and shuts down every 2 hours). I wanted to install CentOS because I've worked with it before for one of my classes, but now I'll settle for anything that works.

    When I first tried to install CentOS, I got up to the point where the setup creates partitions and got an error saying that setup couldn't find any drives on which to make partitions. I found out CentOS was looking for AHCI drives and my Hard drive was configured as IDE (not sure why because it's not an IDE connection). So, I changed it from IDE to AHCI but I still encountered the same problem when I tried installing it again. Now Windows 7 won't start (which is fine cause I don't want Windows 7 anymore), and just about every other Distro I've tried to install gives me the same problem. I recently tried running a LiveCD of PCLinuxOS and got the error:
    Unable to mount the live cd, dropping you to a limited shell
    I also tried running a LiveCD of CentOS before I got into this mess and something similar happened.

    What should I do? The physical connection on the hard drive seems to be ok. Should I try switching back to IDE mode? Is my hard drive irreparably damaged? I don't know a whole lot about Linux and I'm in way over my head any help would be appreciated

  2. #2
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,204
    I have a computer
    Howdy and Welcome. Not a lot of info there to go on.

    With out knowing the make and model of Hardware. Nobody here will know what to tell you.

    Should I try switching back to IDE mode
    Don't know.

    Try giving some more detailed info so people runninbg CentOS and your make of hardware can tell you on how to proceed. Happy Trails, Rok

  3. #3
    Just Joined! gnuuser's Avatar
    Join Date
    Nov 2009
    Location
    northwestern Pa, usa
    Posts
    69
    yes you should switch it to ide mode including the setting for your cd drive ( if it is a sata drive)
    most systems with newer sata drives have different mode settings. primarily designed for speed access.
    most linux distros have a problem with ahci setting and sometimes wont install.
    there is also some different options you can use during the boot process.
    you can probably find more info on the forums for the distro you are chosing to install

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    I switched it back to IDE mode and did a system restore which made windows 7 start again, but PCLinuxOS is still giving me the error message
    Unable to mount livecd, dropping you to a limited shell
    and CentOS wasn't recognizing my hard drive before I tried switching to AHCI mode. So now I'm right back where I started.

  6. #5
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    i would try the newest version of fedora over centos for better hardware detection

    also, i would try linux mint, i've heard nothing but good things about it with hardware detection and it being newbie friendly

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Newer version of Fedora will work fine. I had to set IDE Mode for SATA disks in my old machine.

    Btw, which MotherBoard do you have? Check if new BIOS version available at its manufacturer website. BIOS upgrade might sort out this problem.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    341
    I've had no trouble with opensuse 11.2/11.3 and sata drives and I think set up is easier with opensuse.
    Pete

  9. #8
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    I tried installing the server version of ubuntu and that couldn't seem to detect the hard drive either. I think the issue might have something to do with the way Windows 7 set up the partitions.

    Does anyone know why the live CD won't work? It shouldn't matter if there's issues with the hard drive for a live CD. Why are both PCLinuxOS and CentOS unable to mount?

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Could you post the output of fdisk -l command here?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined!
    Join Date
    Sep 2008
    Posts
    59
    When I type "fdisk" it just says:
    fdisk: not found
    as if the command doesn't exist. I'm thinking the shell it drops me to doesn't have access to that command. I didn't try that command in a command prompt in Windows.

    I don't know if it helps, but when I looked up the info on the hard drive in Windows, the device name was:
    ST3500630AS
    There's definitely something wrong with the hard drive, because sometimes it acts like there's no operating system on it, and sometimes it loads Windows 7 fine.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •