Find the answer to your Linux question:
Results 1 to 6 of 6
Ive been at this the last 3 hours now or so. Im not a very good with Linux, Im fine with all other areas. I have this laptop, with a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4

    PCLINUXOS - Connection Failed (Tried all security modes) so lost and confused


    Ive been at this the last 3 hours now or so. Im not a very good with Linux, Im fine with all other areas. I have this laptop, with a Intel Pro 2200BG card.

    The idea was to install a lxde lightwieght on it, and use PCLINUXOS, because its "easy". This computer is for internet browsing and thats it.

    Under the Network Center -- I can see all networks, including neighbours. When i try to connect to my router via Wireless, I get connection failed over and over.

    I then tried doing all the following
    Changing the router from WEP to, WPA, WPA2 personal, WPA2 Enterprise
    Changing the SSID, broadcasting to ON, changing the SSID name

    Ive used various different passwords, and reset the router now about 50 times.

    I am connecting to my Router (as Ive changed the SSID and noticed it picks up the new name)
    (Yes I can see the correct MAC addreess)
    Yes Im on the right channel,
    all good here.


    -- Hell my Nintendo DS is connecting fine with all the changed settings now, lol

    The wireless card worked fine under Windows XP (However I just removed the operating system since I really had no need for it)

    Ive tried every other mode, it works wired.

    Like i had explained above, I downloaded a what I thought was an easy verison (distro), I was really hoping to get away from the crazy windows life with crazy errors and instability.

    However, Im just flabbergasted again, this is just about giving me grey hairs. This is more buggered up then windows for me

    I read other ppls forum answers.
    and I did try enabling display log, and doing it manually by adding a connection, etc

    The log tells me about as less would a windows event log :P

    it says

    Problems occured during the network connectivity test

    This can be caused by invalid network config or problems w/ your momde / router

    Reluanch, etc



    Lemm eknow

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome. Don't get too upset just yet, it may be a simple problem.
    Try opening a terminal window and issue these commands, post the output back here. You may need to preface these commands with sudo or login as root.
    Code:
    lspci
    Code:
    lsmod
    Code:
    ifconfig
    Do you have a firewall? Do you have wpa_supplicant installed?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4

    Back again

    Hello there,

    Well Im going to have to run it as a WEP network (thats Open WEP or Restricted) tried both

    All three of the commands you gave me it says Command not found

    logged under root@localhost

    However, I gotcha, what your thinking. Im able to scan for networks, but maybe theres improper setup on the card device. However, im looking for something like ipconfig for windows, but ipconfig/ ifconfig didnt work for me.

    Also I want a AP network or Adhoc, I tried both too though

    The WPA package, I just downloaded the OS, however I wont be using WPA as its not going to be compitable for the rest of the devices in the house here.


    Thanks again

    Im putting for WEP 64 Bit

    Using Key 1

    Ten number/alpha

    Key 1 : Generated xxxxxxxxxx im using as the password for the log on to router,

    Ive also tried using a passphrase, no go there either.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4

    [Solved] --- Might as well post exact

    This is what worked for me, and also is included the dont forget stuff

    Wireless Network is AP
    (make sure you match what your wifi card is (eg B , G, etc)

    I set my security to WEP 64 bit
    Security Mode

    Default Transmit Key
    (1) 2 3 4
    Encryption
    64 bits 10 hex digit
    Passphrase
    example wavewave99

    it generates 4 keys via your router (Notice I selected above Key 1

    Key 1 :11C5A112E0
    Key 2:235A112E4
    Key 3:33B5A112Eb
    Key 4:1C25A11212

    In your Linux Configuration

    The settings are to find your wireless network (via the GUI), if its not displayed you may have the broadcast SSID option off on your router, you manually connect to it by finding your Mac address via the GUI, then going from there.

    So I click on my network which got renamed 25 times today, and is now called Supper ( missed supper)

    Click configure

    Restricted WEP not OPEN WEP
    Key : 11C5A112E0

    then go to connect, and should be fine.

    If you dont see any networks in range on the GUI, make sure your card radio is enable via client computer (laptops have a manual switch on them)

    Hope this might help someone someday

  6. #5
    Banned
    Join Date
    May 2010
    Posts
    19
    Quote Originally Posted by confusedandlost View Post
    This is what worked for me, and also is included the dont forget stuff

    Wireless Network is AP
    (make sure you match what your wifi card is (eg B , G, etc)

    I set my security to WEP 64 bit
    Security Mode

    Default Transmit Key
    (1) 2 3 4
    Encryption
    64 bits 10 hex digit
    Passphrase
    example wavewave99

    it generates 4 keys via your router (Notice I selected above Key 1

    Key 1 :11C5A112E0
    Key 2:235A112E4
    Key 3:33B5A112Eb
    Key 4:1C25A11212

    In your Linux Configuration

    The settings are to find your wireless network (via the GUI), if its not displayed you may have the broadcast SSID option off on your router, you manually connect to it by finding your Mac address via the GUI, then going from there.

    So I click on my network which got renamed 25 times today, and is now called Supper ( missed supper)

    Click configure

    Restricted WEP not OPEN WEP
    Key : 11C5A112E0

    then go to connect, and should be fine.

    If you dont see any networks in range on the GUI, make sure your card radio is enable via client computer (laptops have a manual switch on them)

    Hope this might help someone someday
    My 2 cents on this matter:

    to be brutally honest, Mandrake, Mandriva and its forks (which includes PCLinuxOS) are completely trash when it comes to WiFi connections. For some reason, nothing, not even the command line, seems to be able to convince the distros to pick up a connection, regardless of its encyption method.

    While your method you posted may work for WEP secured connections, WPA and WPA2 support on Mandriva and its forks are still completely broken. I have gotten WiFi working on both WPA and WPA 2 in almost every other Debian or RPM based distro (heck, i even managed to get a working connection up in Arch Linux), but everything else just seems to break on PCLinuxOS and Mandriva.

  7. #6
    Just Joined!
    Join Date
    Nov 2010
    Posts
    1

    use command line

    here what i did

    1. scan the wireless :

    iwlist wlan0 scan

    2. key-in the key

    iwconfig wlan0 essid NETWORK_ID key WIRELESS_KEY

    or

    iwconfig wlan0 essid NETWORK_ID key s:WIRELESS_KEY

    3. get the ip

    dhclient wlan0

    by the way command line rock...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •