Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    CAD Installation Problem


    I am trying to install a CAD program called DraftSight. I have downloaded the rpm file and have tried to install it, but I'm getting an error I can't figure out. Following is terminal result:

    Code:
    [root*localhost draftsight]# apt-get install draftSight.rpm
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Selecting draftsight for 'draftSight.rpm'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or that some of the repositories
    in use are in an inconsistent state at the moment.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      draftsight: Depends: libaudio.so.2 but it is not installable
    E: Broken packages
    I'm not sure how to interpret this message as the file libaudio.so.2 and the file it is linked to, libaudio.so.2.4, are located in my /usr/lib64 folder. Can anyone advise me about what to do to make this installation work?

    Thanks

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    14,038
    Read the error messages. You are missing dependencies, and you may have an out-of-date package.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    I did read the message, and I don't understand it. That is why I'm asking for help. I understand that it says that there are missing dependencies. Isn't it telling me that the missing dependency is libaudio.so.2? If that is not correct, how do I find out what is missing?
    How would I determine if the package is out of date. It was downloaded from the DraftSight web site.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,966
    Wrong package format and wrong distribution.
    You cannot install it.

    Read the draftsight documentation and choose the correct package for your distribution.
    If your distribution is not listed, you can then choose to change the distribution or the cad program.
    You must always face the curtain with a bow.

  6. #5
    For linux downloads, there are two choices, .rpm and .deb. Isn't .rpm the correct one for pclinuxos?

    Follow-up: For anyone else that might be interested, it appears that Draftsight does not work on pclinuxos. The Draftsight web site doesn't make it obvious or easy to find, but if you can find "system requirements" (pretty easy) or FAQs (not as easy), you can see the compatible linux distros. Also, if you create a log-on, you can find another set of FAQs with another compatible list (all are slightly different).
    Last edited by WillYum; 09-11-2017 at 08:22 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •