Find the answer to your Linux question:
Results 1 to 5 of 5
Recently I've been playing around with several different linux distro's. I like running the live CD before actually installing it. I have a problem with playing audio though. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    478

    USB Audio problem, HELP!!!


    Recently I've been playing around with several different linux distro's. I like running the live CD before actually installing it. I have a problem with playing audio though.

    I have Gigabyte USB speakers (nothing special, got it for free in a bundle) and I a Logitech headset which also connects via USB. I ran both Mepis and PCLinuxOS live cd's and everything worked perfectly on them, even more on PCLinuxOS if I may say so, but I could not configure my audio...so I have no sound.

    What you're looking at here is a typical Linux newbie with no experience whatsoever, whom has been using Windows for a decade (I'm 17 btw) and who's at the turning point.

    I use the normal on-board sound card on my MSI Neo Platinum 925X and it detects my audio driver by itself....but I don't know if it's correct. (Will post the name of the driver sometime, can't remember it now). Anyhow, when I use the Headset I can hear myself speaking through the speakers but I can't listen to any of my 9889 songs and neither do my videos have sound...they do play though

    Any help on this topic will be greatly appreciated!!!

  2. #2
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    run dmesg and see if there is no problem with there. (just type dmesg at prompt)
    check that your volume is on.
    do lsmod and see if all modules for you souncard are loaded.

  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - That's a lot of songs! It might just be that some of your sound channels are turned all the way down. You need to be aware of which sound system you're using: a popular one - which is probably the best to use - is called ALSA. You'll need to dig around in your menu system and find KDE>Sound or whatever is relevant on your computer

    Assuming you are using ALSA, open a terminal up and type amixer. This is a command line version of the mixer programme. Scroll left and right using your arrow keys and turn up your channels.

    See if that helps. If it does work and you've turned up any of your channels too far you might get some feedback through your speakers. If so, try reducing your channels a bit.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    478
    It is set on ALSA, that's what my Control Center says, but when I do lsmod it says the following ...*roughly* (I'm not quite sure whether it's lsmod which I ran that gave me this but in the Control Center it gave me a few options to run and when I ran a certain one it gave me this...

    sound: 0: off 1: off 2: on 3: on 4: on 5: on 6: off
    I'm not quite sure what this means and I don't know how to turn 0,1 and 6 on...Remember, this is my first time using Linux actually. I used to just play around with the GUI, now I'm officially trying to switch from windows to some distro that is cool. I have SuSE 10.1 and Mandrake 10...oh and CentOS (Very similar to red had apparently)

    Thanks for the replies, I'll try at home

  6. #5
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    478
    Well I have the following information, I don't know if it will help but I do hope so!!!

    Sound Driver: snd-hda-intel [ALSA]

    When I switch to any other driver AmaroK and XMMS does not play the music (If I look at the bouncing
    lines etc. lol) But when it's on the default intel [ALSA] driver it does. So this must be a problem with
    the USB speakers. According to my brother the USB speakers don't use the sound card in order to play, but
    instead has it's own "built in" little sound card of some sort...so I'd like to know if anyone can help me with this
    or should I go and buy myself some cheap regular non-usb speakers and save the effort?

    Thanks in advance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •