Find the answer to your Linux question:
Results 1 to 3 of 3
Greetings So far I have not been able to find a LiveCD distro that has had success with my motherboard. WindowsXP Pro runs OK for the most part and uses ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    nForce3 250gb chipset and LiveCD distro's


    Greetings

    So far I have not been able to find a LiveCD distro that has had success with my motherboard. WindowsXP Pro runs OK for the most part and uses the on board network adapter without much fuss but any LiveCD distro I have tried can't seem to get the module or whatever it is configured properly. They seem to see the on board NIC/hardware but it doesn't go past that.

    I've spent days trying to figure out what is wrong and am still stymied. From what I understand so far is that it is the <forcedeth.c> module or driver and it is supposed to be common, or at least that is my impression.

    One of my suspicions is that perhaps the on board network LAN adapter is somehow ROM locked or some such thing. I really want to rebuild this system with a dual boot config but I can't do that until I am sure that this is a problem that I can overcome which is why I have gone through about eight LiveCD distros so far to no avail.

    With another computer on my LAN going to a router before hitting the network bridge, I have had success with several LiveCD distro's but that computer is a totally different hardware configuration. Point being that I am reasonably confident that this isn't a router issue.

    (Actually while writing this post, as a sanity check I just booted my laptop with PCLinuxOS which is on my LAN and other than having to use a special boot parameter for a minor frame buffer gaff on this Dell Laptop, it works fine for network ability and I am browsing with it as I write this post.)

    The system is currantly using a RAID+0 setup which is one of the reasons I am trying out various LiveCD distro's. I don't want to begin a rebuild process unless there is confidence that the system is Linux friendly. I plan to end the RAID+0 setup.

    I hope someone can give me some insight to this problem or at least spur some thoughts that have potential to lead to a solution. I would really like to get this (my main computer) system dual booting and start the weening process from Windows but I can't do that until I either have confidence that this system is GNU/Linux capable or I decide that the solution is to purchase a NIC card and try that kludged route. :-/

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    I've encountered forcedeth, and I read it as Force Death. I don't remember for sure the issues or what I did.

    However, in the file /etc/modprobe.conf I have this line, which I vaguely recall is the solution.
    Code:
    alias eth0 e1000
    Another machine has "alias eth0 8139too".

    I think these lines correspond to the results I see when I run this:
    Code:
    $ dmesg | grep eth
    One PC shows "Intel(R) PRO/1000 Ethernet", the second shows "RealTek RTL8139 ..."

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    Thanks for the attempt of help. This issue has been resolved.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •