Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    [Solved] CD-ROM drive not detected

    Hi. I am new to Linux.

    I tried to install Linux from a CD or DVD, but everytime the installation could not seem to find the media. I have tried Fedora, Ubuntu, Slax, and Knoppix.

    I finally got Fedora core 5 to install by using the FTP option to get it from the internet, and it installed fine. Now I want to get the optical drives to work.

    I have a Gigabyte GA-965P-DQ6 motherboard with 2 optical drives, both IDE. One is a Gigabyte Combo drive and the other is a Samsung DVD Burner. Northbridge: Intel P965 Express Chipset; SouthBridge ICH8R Chipset.

    I am guessing that because many distros did not install, the problem has something to do with the motherboard itself. I do not know if I have a setting incorrect in the bios or what. I noticed, though, that after I bought the motherboard, on the gigabyte site it said that there are chipset drivers to download for the different linux distros. If this is all I need, could I please have the links on where to download and how to install them?

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Does the disk even boot? Have you run any other OSes, and do they recognise the drive?

    Do you see any activity in the drive at all?

  3. #3
    Yes, Windows does install, works with this motherboard, and recognizes both drives. The motherboad came with the chipset drivers for Windows.

    EDIT: I have a question that may have to do with this. Does linux have a limit to how many IDE Channels it can sense? Because the CD drive is on channel 4.

  4. $spacer_open
  5. #4
    I've got the same pb, I can't install any version of linux with the MOBO GA-965P-DQ6 : cdrom device not found.....

    I tried Suse, Mandrake... and always the same pb...So please help us to found a solution

    Many thanks in advance

  6. #5
    I found a solution. At the grub boot line, at the end, put in all-generic-ide. Both of my drives appeared after I did this.

    I got this information from this thread:

    It seems that it is the P965/ICH8 chipsets that have this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts