Find the answer to your Linux question:
Results 1 to 5 of 5
I am having problems porting an application from Win to Linux. It talks to an FTDI USB-serial chip. I am using the FTDI supplied 'direct D2xx' library (version 0.4.13). Installation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2

    USB - FTDI D2xx drivers


    I am having problems porting an application from Win to Linux. It talks to an FTDI USB-serial chip. I am using the FTDI supplied 'direct D2xx' library (version 0.4.13). Installation seems OK, as some functions seem to work OK.

    However, my problem is that the function FT_GetDeviceInfoList() gives all nulls for the various information fields (eg description, serial number, manufacturer, etc). The functions FT_GetDeviceInfoDetail() and FT_ListDevices() fail similarly. The function FT_CreateDeviceInfoList() returns the correct number of devices connected (tested with 0,1 or 2 devices).

    The system knows the correct information about the devices, checked by both the KDE program KInfoCenter->USBDevices, and the program 'usbview'.

    Has anyone had success/problems with this, especially running 2.6 kernel (I have 2.6.18, fedora 6) and version 0.4.13 of the FTDI library?

    I have tried support at FTDI but they have not responded at all!

    Thanks,
    gl2008

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    5
    I've got a same problem but found that it works OK if run under the root. I guess that lib is trying to access something in /dev/blahblah and permissions are not set properly. Any idea how to find what exactly it is trying to access?

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2
    Yeah, the best suggestion FTDI came up with was run as root, or try other distro's/versions. This was to be for a commercial application, and my customer got concerned about the implications of this fickleness of the drivers. Consequently it got put down the priority list, and I haven't searched for the exact cause. However, I would be most interested if anything more is found.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    5
    After wrestling for a bit I gave up and used a workaround - I wrote small service which accesses FTDI chip and runs at system startup as root then creates a pipe (I used this as an example - 6.3.3 FIFO Operations ). User application uses the pipe to comm. to service which comm. to FTDI and back thru another pipe...

  6. #5
    Just Joined!
    Join Date
    Nov 2008
    Posts
    1

    USB on fedora

    I don't know if there is anyone found a resolution, I have not tried this, but will hopefully get my interface up in a few days.

    As far a permissions, you should try to make your own rule in /etc/udev/rules.d
    This would be for a 2.6 kernel. I wanted to access my USB devices with libusb and could not read them unless I was logged in as root. I picked a rule number and added this rule:
    ATTR{idVendor}=="0D7D", ATTR{idProduct}=="1400", MODE="0666"

    The idVendor and idProduct are for my USB drive. When I ran my code I was able to read the device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •