Find the answer to your Linux question:
Results 1 to 5 of 5
I can successfully launch and work with Eclipse under root in Debian. But when start it under non-privileged user I get: Code: !SESSION 2010-02-19 17:27:41.673 ----------------------------------------------- eclipse.buildId=M20090917-0800 java.version=1.6.0_12 java.vendor=Sun Microsystems ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3

    Eclipse Galileo starts with exception on Debian


    I can successfully launch and work with Eclipse under root in Debian. But when start it under non-privileged user I get:

    Code:
    !SESSION 2010-02-19 17:27:41.673 -----------------------------------------------
    eclipse.buildId=M20090917-0800
    java.version=1.6.0_12
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
    Framework arguments:  -product org.eclipse.epp.package.java.product
    Command-line arguments:  -os linux -ws gtk -arch x86 -product org.eclipse.epp.package.java.product
    
    !ENTRY org.eclipse.osgi 4 0 2010-02-19 17:27:42.671
    !MESSAGE Error reading configuration: Permission denied
    !STACK 0
    java.io.IOException: Permission denied
    	at java.io.UnixFileSystem.createFileExclusively(Native Method)
    	at java.io.File.checkAndCreate(File.java:1704)
    	at java.io.File.createTempFile(File.java:1792)
    	at org.eclipse.osgi.storagemanager.StorageManager.initializeInstanceFile(StorageManager.java:188)
    	at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:692)
    	at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initFileManager(BaseStorage.java:213)
    	at org.eclipse.osgi.internal.baseadaptor.BaseStorage.initialize(BaseStorage.java:147)
    	at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage(BaseAdaptor.java:121)
    	at org.eclipse.osgi.framework.internal.core.Framework.initialize(Framework.java:185)
    	at org.eclipse.osgi.framework.internal.core.Framework.<init>(Framework.java:157)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:286)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
    	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
    	at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
    What permissions should I set up? Thanks.

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Location
    Maryland, USA
    Posts
    82
    Your non-privileged user permissions do not have the accesses necessary to read the Eclipse configuration files and (probably) the other folders needed to run Eclipse.

    I don't know the best way to fix the problem, but you could reinstall Eclipse as the non-privileged user so that you'd have access to all of the files and folders necessary to run as a user other than root.

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    I don't understand how reinstalling Eclipse can solve my problem. The problem is what permissions should I set up to launch Eclipse under non-privileged user?

  4. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    I solved my problem. Previously eclipse was unarchived under root so some files and directories in eclipse were unavailable for simple user. I unarchived Eclipse under this simple user and now all is working fine.

  5. #5
    Just Joined!
    Join Date
    Dec 2009
    Location
    Maryland, USA
    Posts
    82
    Sorry that I didn't understand that your original post defined a minimal solution set.

    Essentially, you reinstalled Eclipse so that it was accessible to unprivileged users, and it solved your problem without messing with permissions on the original install. Congrats.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •