Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    ctrl_alt_del doesn't work.

    I have built my own very minimal boot disk using the Pocket Linux guide.

    But the key combination ctrl+alt+del doesn't work.
    Also I'm not able to get bash to interpret the /etc/inputrc file even after compiling bash with --enable-readline option.

    So, how do I make bash interpret /etc/inputrc file and other environment variables like PS1, even if I don't have multi-user capabilities?

    Please help.

    Vinuth M Madinur.

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    London, UK
    Ctrl-alt-delete must be defined in /etc/inittab.

    Typical entry:
    ca::ctrlaltdel:/sbin/shutdown -t3 -r now
    Good luck

  3. #3
    I'm not doing this on FC2. I'm doing this on a small rescue disk.
    I already have that entry in my /etc/inittab file.

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    London, UK
    I presume bash is invoked as login shell on your boot disk?

    Bash first reads the file /etc/profile then looks for a user specific file ~/.bash_profile

    I belive there is a nice long chapter about this in the bash man-page.

    Simply put, make .bash_proifle call .bashrc and make .bashrc first call /etc/bashrc and then set your user settings. That will take care of all shells both login and non-login shells.

    Inputrc is read from ~/.inputrc or $INPUTRC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts