Find the answer to your Linux question:
Results 1 to 4 of 4
I am running a C++ application which calls .so library at the time of execution. But while running, it gives below error - rtld: 0712-001 Symbol __ct__3ETDFv was referenced from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    2

    Error while running .so file


    I am running a C++ application which calls .so library at the time of execution. But while running, it gives below error -

    rtld: 0712-001 Symbol __ct__3ETDFv was referenced
    from module /bancs/aml/lib/libmonitor.so(), but a runtime definition
    of the symbol was not found.
    rtld: 0712-001 Symbol etd_insert__3ETDFv was referenced
    from module /bancs/aml/lib/libmonitor.so(), but a runtime definition
    of the symbol was not found.

    I checked for all libraries. There is nothing missing.
    I am running this on AIX where LIBPATH is also set correctly.
    Any Solutions ?

    Thanks.

  2. #2
    Linux Newbie
    Join Date
    Apr 2010
    Location
    Novosibirsk, Russia
    Posts
    145

    Post

    Runtime definitions missing for 2.2.8 on AIX 5.3 | Apache | Users

    the firlst link from Google Search results....

  3. #3
    Just Joined!
    Join Date
    Feb 2011
    Posts
    2
    Hello,

    I have already read it but it does not help.
    Actually my applications is running on one server but not on another server.
    OS level and xlc versions are same on both the server.
    I also tried to copy the .so file from working server to another one but it throws same error.

    Thanks.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,444
    The missing symbols are likely in another library or libraries that are either missing or not in the LIBPATH or LD_LIBRARY_PATH environments on the system where you get the error. Is the executable that won't run the same build (a copy) from the system where it does run? Or was it built separately?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •